Cannot restore Nibble Firmware

Hi, I’d like to restore my son’s Nibble firmware but we can’t seem to via the GUI. We keep getting a JS error:

CleanShot 2022-06-25 at 17.51.01

We’ve tried reinstalling both CircuitBlocks and Arduino but still get the same error.

We’re on macOS 12.4 and a M1 Max if that helps.

1 Like

Heyy @gcaprio,

thank you for reaching out.

Can you let me know if your Nibble worked properly before trying to restore firmware?


Yes, though we have a custom program we wrote on it with some bugs. That’s why we want to restore the firmware and start over.

1 Like


thank you for the reply.

Please try (running the sketch/restoring the firmware) again so the error occurs again, then go back to the home page in CircuitBlocks, scroll to the bottom, and in the footer you will find a “Send error report” button.

Clicking it will open a window showing all the information which will be sent, which includes the error that happened as well as some other info about your system that might help us resolve your problem.

When you click “Send report”, the report will be sent to tour servers, and you will get a report ID. Please get back to us with that ID and we’ll be able to assist further.

You can send the error report ID to

Best regards,

OK, great, email & error report sent.

1 Like

Thank you so much! :slight_smile:

We’ll get back to you with the solution asap!

1 Like

Hi there!

I have the same situation. My Nibble works fine, but after uploading a custom program I cannot restore the firmware. I get the same error message as @gcaprio. I use MacOS 13.1 and CircuitBlocks 1.9.2

1 Like

Hey @outsider,

can you please send us the error report ID to so we can check it out?


fyi, I finally tried again and uninstalled everything and reinstalled both Arduino & CB. I also manually installed the Arduino boards and I was finally able to restore the firmware successfully!

1 Like

That’s amazing! :slight_smile:

Great job

I have the same issue but im on windows I uploaded the game from circuit blocks and I am unable to revert to my normal nibble it just came up with this

1 Like

Hey there,

Please try restoring firmware once again, and once it fails, click on the send error report and send me the report ID you get.

Thank you in advance,

Thanks It been a couple of days and I got it to work!

also how do I add a game without getting rid of the original firmware.

Same thing happened to us! Did you get it resolved ok?

Same thing happened to us today on a mac, too! I’ve put int a ticket, but also curious how others may have resolved the issue.