Can't upload to Nibble

Just built my Nibble this weekend and it working great!

However I can’t get CircuitBlocks to upload to it. I get the same upload error message every time. Also when I try to restore the firmware. See the screenshot.

I’m using CircuitBlocks 1.3.1 on a Mac with Big Sur (11.2.1). The Nibble is turned on and CircuitBlocks says ‘Nibble Connected’.

Since my Mac only has USB-C connections I’m using an adapter to connect. But I tried a few and with the same result each time.

Any idea what is going on and how I can troubleshoot?

Thanks!

Dear @bob,

Apple has released an update for Mac which completely stopped the compiling and sketch uploading to all esp32 and esp8266 devices.

We’re working hard on fixing this problem.

Thank you for your patience and understanding!

Dora from CM

Dora,

Thanks for the update. Good to know it was probably not an issue on my end. I’ll wait for an update to CircuitBlocks.

Let me know if I can provide additional information or test something.

Bob

Dear @bob no, it was not your fault. Keep an eye on our updates, we’re working as fast as we can to fix this problem!

Hi @doraCM, do you have an update on this issue?

I see CircuitBlock is still at the same version as it was in February. I realize it might be complex to solve, at the same time it is a bit frustrating that I can’t really do anything with the Nibble.

Hey, Bob.

This was an issue that was fixed by pushing an update to the CircuitMess Arduino package, which should have been downloaded automatically by CircuitBlocks. If the issue persis, please contact us directly at [email protected] so we can help resolve your problem more efficiently.

Filip

Thanks for the update. I will give it a try later this week and report back.

1 Like