CircuitBlock not running

I have installed the circuitblock but when i tried to run it displays this message

Command failed: C:\Users\Petros PC\AppData\Local\ArduinoCLI\arduino-cli.exe config init ‘C:\Users\Petros’ is not recognized as an internal or external command, operable program or batch file.

I have reinstalled it but the problem not solved.

It happens because your username (“Petros PC”) contains a space. There are several charakters messing up the installation if you have them in your username. I had the same error on another PC because my username contained a “-”.

Unfortunately I don’t have a proper solution for this problem. You could create another User on your PC with a new Username like “PetrosPC” or something similar.

The issue seems to be present since the very first version of CircuitBlocks as @robertCM wasn’t able to help me back then too.

Hey guys!

Thanks for making us aware of the issue. Seems there was a miscommunication between @robertCM and me the last time and we haven’t gotten around fixing this.

I’ll push an update for CB by tomorrow which will fix the error and let you know in this thread.

Filip