CircuitBlocks will not compile

hi, i am using Pop OS, every time that I try to compile code( even if I haven’t coded anything yet) and I get a compile error, #102. please help


Hey there!

Could you please try compiling something for the Ringo directly from the Arduino IDE? This way we can rule out if this is an Arduino issue, or a CircuitBlocks issue :slight_smile:


I tried it in Arduino and it said this Arduino: 1.8.13 (Linux), Board: “Ringo by CircuitMess, Minimal SPIFFS (Large APPS with OTA), 80MHz, 921600, None”

fork/exec /bin/xtensa-esp32-elf-g++: no such file or directory
Error compiling for board Ringo by CircuitMess

Hello again.

That is quite a strange bug, I must say. Almost as if Arduino doesn’t detect the installed compiler. It could be happening due to a corrupted install. Please try reinstalling the Ringo platform to see if that fixes the issue:

In short: Delete the ~/.arduino15/packages/cm directoy.

In detail: Open your file explorer and go to your home directory, then enter the .arduino15 directory. That directory is a hidden one, so if it isn’t listed, press CTRL+H to show hidden directories. Inside the .arduino15 directory, enter the packages directory, and there delete the cm directory.

After deleting the package, start CircuitBlocks again and it will reinstall it.

Let me know if that fixes the issue.


hello, I tried it again and it compiled about halfway before giving the error.


Getting to half way tells me we fixed the initial error, but now got another one. Could you please try compiling again and then send another error report?


Hello again, I tried it in Arduino and it did not have an error this time, but it still has an error in circuitblocks.


As I said, the original error got resolved, but we have another one now. Please try compiling a sketch using CIrcuitBlocks again so the error occurs, and when it fails go back to the home screen, scroll to the bottom, and click “Send error report”, followed by “Send report” in the report pop-up window. This way I will get the exact error that happens along with other data related to it and will be able to help you further.


ok, The error report is #104. Thanks.


Hey, Blaze

Looking at your last error report, it turns out you are missing python and some python packages which are required for compilation and upload. Unfortunately due to Linux’ sheer fragmentation and number of different distros, we can’t possibly make CircuitBlocks work out of the box for every machine, and errors like this pop up here and there. But fear not, we’ll get it up and running in no time.

I have now installed Pop_OS in a virtual machine to get your exact setup, recreate the error and write up a solution.

Open up a terminal, and enter the following command:
sudo apt -y install python
After pressing enter, you will be asked for your password to install python. While entering the password, no characters will be displayed in the terminal window, so after you enter it just press enter.

After python is installed, next you will need to install the python package installer (pip) with the following command:
wget -O - | python
This will download and automatically install pip for your local user, with the binary located at ~/.local/bin/pip.

Finally, you will need to use pip to install the pyserial package which is used to upload a binary to the device via a serial connection. In the terminal window, enter the following command:
~/.local/bin/pip install pyserial

After that command has finished, you can close the terminal, open up CircuitBlocks, and hopefully, everything should work now.

Let me know if you need any more help :slight_smile:


Hey, it worked! Thanks a lot!