Compile error. Check your code then try again

CircuitBlocks wont compile anything I give it. Compile error. Check your code then try again.

#include <MAKERphone.h>

int Var;

MAKERphone mp;

void setup() {

  Var = 1;


void loop() {

  while (Var < 10) {
    Var += 1;



That is very odd. I just tried the same code and it works like a charm.
Can you maybe try re-installing CircuitBlocks? Or starting a new project?

Does the error appear as soon as you click run or after some time?


Same issue here. I tried reinstalling CB (1.0.2) on my Mac, starting a new sketch, etc. The error appears basically as soon as I hit "Run’.

Possibly worth pointing out: I already had Arduino, and the CircuitMess board support, etc., installed. My other Mac, which didn’t have the other things installed first, can compile – but then, that Mac is the one that always says the phone is disconnected.


I had the same message appearing and I solved it by changing the USB port even if CircuitBlocks was indicating I was correctly connected.

Hope it helps,

1 Like


Thank you for this post! Hopefully someone will find it helpful. :smiley:

I am having the "Running: Compile Error. Check your code then try again error. "
I have a Windows machine.
The error prompts halfway through the progress bar read out.
I have have pasted in the code above, changed USB ports, & reinstalled CB.
I don’t have a functional SIM card in the phone (I don’t think that would be related).
What else could it be?

Hello there,

Thanks for getting in touch!

There could be a couple of things here.

Firstly, make sure that the phone is connected AND TURNED ON before starting the upload.

Secondly, you have to worry about your code. This seems to be a compilation error and that means that there is an error in the blocks. Did you try to upload something simple, that you are 100% sure it should work?

Also, there is a ‘Send error report’ button on the main screen that you can click and then we’ll get a little bit more info about the whole thing (you just send us the report number). :slight_smile:


Was there ever a fix to this issue? I am getting the same exact problem and can’t find any info anywhere on what to do. Running on Windows 10 64 bit.