Connection and upload first program

Well, I came up with the first question about uploading a program to MAKERBUINO.

I followed the tutorial indicated in GAMEBUINO, ( ) but I think that maybe needs updating.

At the moment I charge an example program from the list that exists for GAMEBUINO, compiles it well, but at the time of uploading it to the console it gives communication error.

I think my mistake is in the choice of the chip programmer, but I’m not sure.

Has anyone managed to upload a program to the console and could you tell me what steps you have followed?

Thank you.

I haven’t worked with this yet, but I think you need to compile the code onto the SD card somehow. Your current program is set to go to the ATMega, but I think the makerbuino is set up to look at the files on the SD card.

Unfortunately I cannot help you any further as I haven’t yet had the opportunity to try myself.

No, you have no port defined. You should have a COM port installed (you can you on Arduino website for this part their tutorial is very good). When the COM port (a fake COM port simulated with USB) is created, you should see it in place of the gray “Puerto” shown on your screenshot. The choice of chip programmer is good (Arduino / Genuino Uno).
You’ll be able to update using the plueg serial interface and a USB cable between it and your PC.

I hope it’s will help you and if you encounter anymore problem or need some more specifical specifications please ask and i’ll try to help.

@gabimarti: I was been able to test my game several times this way while I was developing it. This is all the things that you shoukd check:

  • Are you using the programmer? The microusb port of the makerbuino is only for charging.
  • Is the programmer connected correctly? Look at the back of the makerbuino and programmer, and connect every named pin in the console with the same pin in the programmer using the colorful cable that came with the makerbuino.
  • Are the drivers of the programmer correctly installed? If you go to the device manager, you should be able to see it in the “COM ports” section. In arduino IDE then you should be able to select the same port, as @Jean-Charles_Lebeau said.
  • Even with all well connected, I sometimes had problems uploading to the makerbuino. I think it is due to my old pc power supply. What I did was disconnect the jumper (the little black piece that bridges two of the pins in the programmer) from the programmer. This way, the programmer would not try to power the makerbuino, so it powers itself from the battery, wich is a more stable power supply :wink:

Hope you get it working :slight_smile:

1 Like

Thank you all for your comments and help.

Finally I found the problem, and it was due to the voltage as indicated @luke27. The truth is that I did not want to touch the jumper of the programmer that was set to 5V because I did not find specific information and I did not want to damage the circuit. I have set it to 3V and it has worked perfectly to send the program. I have also tried it without the jumper and the program also loads. Again, thank you very much all for your advice.

Thanks. Trying to put program in SD is the next step, but first is it possible to put with the programmer. :wink:

Also, thanks for comment.

Yes, i has also choiced a COM port. The problem was the voltage of the serial programmer. :sweat_smile:

1 Like

Nice, i’m happy that this problem is solved and your post will probably help some others who could meet same problem :wink:

1 Like

Actually, I’m still having the problem of uploading. I have tried the above, changing the jumper pins to the different voltage, or even without the jumper. I’m getting the following error:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xa5

It was working fine just yesterday. Now it has one red LED flashing every second. I have checked all connections too. Everything seems fine just as it was when it worked before.

Any help is appreciated. Many thanks in advance.

After it “attempts” to upload, the screen on the MAKERbuino goes blank, as if expecting data. When I retry the upload, the screen returns to the SD loader while it attempts to upload agian.

Nevermind!! I had the pins connected the wrong way round.
The board and the programmer pins have marked letters.
Make sure you have the wires/pins connected to the same pins, GND to GND, CTS to CTS etc.

Man I feel stupid lol.