Display showing nothing

Hi) I was playing a game on my phone when I accidentally pushed the on/off button. Now it doesn’t start or the display module is glowing all white.

Please advise if there is any full/complete reset procedure or any way to diagnose the display module. Thanks)

Have you tried simply pressing the reset button at the lower right side of the brain board (easily pressed from right side of phone)? It is labeled RESET on the board. If it doesn’t do anything, press the ON button just above it first.

Thanks for that, but doesn’t help, unfortunately: nothing changes. The device clearly reboots, but the display only shows complete white. I guess, there’s a problem with the display module. :frowning:

Have you tried the same reset but with the SD card removed?

Hey, that seems a little bit weird. We’ve never seen that one before.

Can you please download either CircuitBlocks or Arduino IDE and flash the default firmware on the phone? That should easily fix the problem.

If it doesn’t, contact me so we’ll figure something else out! :slight_smile:

Cheers,
Robert

Thank you for that piece of advice as well. Sorry, nothing changes, same result :frowning:

Thank you, Robert. I have downloaded Arduino IDE and followed this installation manual: https://github.com/CircuitMess/CircuitMess-Ringo-Arduino-packages/blob/master/Installation.md. Can you please advise where I can get the “default firmware” you are referring to in your reply? Thanks!

Make sure you have — Board: “Ringo by CircuitMess” installed under the tools menu. You will see at the bottom of that menu - Burn Bootloader. That will install the latest version of the firmware on your phone.

It’s here, under number 13:

  1. Whenever you want to re-upload ‘Default Ringo Software’ you have to go to Tools -> Programmer and select “Ringo Firmware” .

Now go to Tools -> Burn Bootloader and you will have the default firmware on your Ringo as soon as the upload is finished.

Now I see that the images are not displaying since we’ve migrated our server. They will be back up soon, but this is pretty straight forward, you’ll get it done no doubt! :smiley:

Cheers,
Robert

Robert, thanks for that. Unfortunately, I am stuck at number 8. :frowning:

  1. you haven’t already, connect your Ringo phone to the PC via micro-USB to USB cable.
    It will connect to one of the COM ports.
    Go to Tools and under Board section select Port and find the port on which Ringo is connected.
    NOTE : If Port is greyed out it means the phone is not correctly connected.
    Change USB port and/or check your cable.

Well, the only port I have available is Bluetooth, and I don’t think it’s the one on USB. :slight_smile:

You don’t have a USB port on your computer?

If you have USB-C only, make sure to get an adapter because you need to connect your phone to your computer via cable in order to do anything. Once Ringo is connected, make sure it’s turned on so that Arduino IDE can recognise it. If the phone is turned off, it won’t show up in the Arduino menu.

Robert

Thanks) I only have USB-C indeed, but I am using an adaptor (. The phone is turned on, of course.

If you have more than one USB-C port, try them all. Worked for me.