I need help with this code

Hi can anyone help with this code I keep getting this error message every time I try to upload a sketch to makerphone also is it normal for my makerphone to turn off when it says uploading on Circuit blocks


This text will be hidden


Thanks for supporting this project!

Does this happen with every code you try to upload or not?
Also, did you try uploading the same code by using Arduino IDE?

The phone is supposed to turn off since its memory is being rewritten, yes.

Stay in touch, we’ll sort it out! :slight_smile:

1 Like

This happens every time I try to upload a code the phone will turn off and then a few seconds later I will get this message and the phone will restart I have tried coping the code to arduino ide and I selected the port and board to the makerphone and it still fails
Hope you can help


Can you please try switching the cables? It seems like that could be the main issue here, since it doesn’t work on multiple platforms.

Cables are very sensitive and very important part of the data transfer so it might be the main reason for this fuss.


ok I will try that im currently using the include cable btw

it still doest work the same error

Okay, this is now getting very weird.

On the home screen of the CircuitBlocks there is an ‘Error report’ at the bottom of the screen.

Would you be kind and send that one so we can check exactly what is happening inside the program when you’re trying to upload?

Thanks in advance!


Ok I will send a errr report as soon as I can in the meantime is there any other way for me to code makerphone?

The Arduino IDE should always work fire if the setup is done correctly.

Did you do everything in this process? https://github.com/CircuitMess/CircuitMess-Ringo/blob/boardArduino/Installation.md

Also, can you please send me a screenshot of what happens when you try to upload the code using Arduino IDE?


this is what it says when I try and upload a program to ringo

hello I do need help still :slight_smile:

1 Like

That’s a connection error. Did you try to reconnect Ringo?
Edit - I noticed it’s a different day. You’re still having the same error?

1 Like

Yes I’m still having that error and no I don’t reconnect Ringo I press upload sketch and wait only to get that error message about a minute later

Well, first that’s a connection error. If you can’t upload it to Ringo, then you may be experiencing problems with your drivers.

Here is an Arduino with a similar problem.

Ok I will give that a go

1 Like

yay it worked thank you

1 Like

Hey @Samilpatel05 sorry about that!

Was talking to my colleagues about this problem and we’ve come to conclusion that there is a connection problem, just like @8bitRobot pointed out!

Glad to see it solved, thank you very much!

1 Like