LEDs won't work in CircuitBlocks Programs

Hello,

the LEDs of my ByteBoi work fine during the hardware test program, but they won’t do anything if I try to use them in my own programms or if I complete the tutorial.

I even tried to do a very simple program like the following:

Could you please help me, what am I doing wrong?

bye
Kolia

1 Like

Hi @Kolia,

thank you for reaching out.

Sorry to hear that you’re having problems with coding your device.

Can you please contact us at [email protected] so we can help you?

Sincerely,
Monika from CircuitMess

Wouldn’t it be more helpfull to discuss it here?
Maybe the solution is also interesting to others.

I tried it now on 3 different PCs neither my code as shown above lets the LEDs glow nor the example code from CircuitBlocks. During the hardware test program the LEDs work just fine.
Maybe there is something missing in the genereted code of the setRGB LED color block?

1 Like

Hi @Kolia,

thank you for your reply.

I’ll check this out with our programmer and get back to you with an answer as soon as possible.

Sincerely,
Monika

Hi @Kolia,

hope you’re doing great! :slight_smile:

Can you export this sketch binary and send us that file to check where the problem might be?

Also, it would be helpful if you could add a block into the “When button gets pressed” block so we can check if that part of the code is working properly.

Thank you in advance,
MonikaScreenshot 2022-01-13 150324