Makerbuino has stopped working

Hi everyone am looking for some advice please
Makerbuino arrived yesterday and all built, tested and working great. Son has been playing games and really happy.
Suddenly this morning, it is no longer working. The screen comes on with the switch (leds light up) however the screen remains blank, no sound and nothing happens.
Have tried removing and reinserting processor, sd card and charging battery, but still nothing. Is it possible one of the components has developed a fault already and any clues as to which one. I’m happy to go to an electronics shop and pick up a replacement component if I have any idea which one.
Many thanks for your help.
Matt

1 Like

We have exactly the same problem (screen lights up, but nothing else happens). Finished the build yesterday and has been working really well. I’m currently in the process of diagnosing the issue and will post back with my findings (if any).

It would be good to get some suggestions from the team in the meantime.

We managed to fix it last night. Turned out not to be a hardware problem after all and a software issue.
It can be fixed by switching off, then holding button c down and switching back on. Once on let go of button c and wait 3 seconds and it all is good to go.
Hope that works for you as well!
Matt

2 Likes

I narrowed it down to the either the crystal or associated 2 caps, as the chip was responding just fine when tested on a breadboard.

I did the reset as you suggested and indeed, it all worked fine again. Thank-you :slight_smile:

I assume that’s some kind of reset feature. How did you find it?

UPDATE: While this did resolve the issue, the screen continues to freeze frequently. Doing this reset fixes for a very short period before it ‘crashes’ again. Looks like @albertgajsak will need to investigate this further as it does indeed to be a software issue.

We’ve had this happen three times over 48 hours. I found the solution by chance on another thread on the forum. Would be interested to know what causes it, and whether there is a bug in the software that can be easily ironed out.

What I can work out is that the MAKERbuino software is based on or the same as used by GAMEbuino.
I can only predict that this sounds like a reading issue from the SD card which has corrupted the processor memory, this then causes the current issue you are experiencing. Pin pointing the software issue isn’t going to be an easy task.

The MAKERbuino SD card has a file called LOADER.HEX, See GAMEbuino wiki which explains the following:

If the C button is held down while the unit is powered-up then the bootloader will search for a compiled sketch on the SD card called “LOADER.HEX”.

This will then reset the bootloader and in turn fix the issue.

The GAMEbuino wiki link HERE

1 Like

Hello
Same issue here…

Solved with holding the C button.

Best Regards

I found myself here on this thread tonight.
Had the same issue. Backlight works when powered up, but nothing else. The device had been assembled as per instructions, and had been working for one day, used for about 3 hours all up.
I got home, tested the 3.3V regulator, found that to be fine.
Next I checked the crystal side of both 22pF capacitors with a 100MHz oscilloscope, found a nice clean 16MHz sine wave on both. No problems here.
Next checked for any data on the I2C and LCD and found no data.
Came searching on the forum, and the reset procedure described with the C button worked a treat.
Wish I had known this earlier today.

@Eddie Some things are out to test us!!.. glad that you got it working with the C button reset :slight_smile:

I have the same issues as above, but holding the C button on booting doesnt solve it for me. Still only lights on screen. Tried to charge it just to be sure there werent a low battery issue, still doesnt work. Any ideas`?

@Robin Did the screen originally work and has now stopped working or have you always had a black screen? If it was always like that, please upload some pictures of both sides of the board without the case and screen so we can have a look at it.

the same issue as described above, and solved with C button while turning on
now we will see how much will lasted :wink:

danijel

thanks it worked but it didnt take three seconds it took much longer just in case people would want to know that
Thanks

@loverugby,
When you interrupt the loading process, the console’s memory will be blank so you have to do a hard reset like this:

  1. insert the SD card
  2. turn the console OFF
  3. hold the C button
  4. turn the console ON
  5. release the C button
  6. wait for 30 seconds
    The SD card loader menu should appear.

This is also described in build guide’s chapter #4 (the yellow section at the end of the page marked “important”).

My 10 year old son put the Makerbuino together, and it was working fine, but then the screen stopped working, and only the backlights work. I have tried the C button reset but this has not worked. Can anyone help as he is very keen to use it! Thank you in advance.

@8uri,

Thank you for supporting MAKERbuino and I am sorry for the problems that you’re experiencing.

We can see your post in the support category and will respond ASAP, there is no need to create multiple posts for the same topic.

Thank you for your understanding