New Ringo -- cannot update firmware or connect via USB (Mac)

Hi Everyone,
My son decided this weekend was when he was going to finish putting together his Markerphone and he was delighted it started up without any problems. This was his second project after the Makerbuino so a little more experienced.

This is the base (2.5G) Ringo and has no SIM since we are based in Japan.
Current firmware version is 0.9.9 - check for updates connects to my Wifi (unprotected) fine and detects 1.10.5 as available. It reports downloading software do not restart and after about 20 seconds displays “Error while downloadin g Reverting firmware!” and restarts.

Deciding that maybe upgrading the firmware via the Mac would be a better idea I followed the steps to install Arduino and CircuitBlocks. Connecting the USB cable causes the Ringo to light-up and being charging so it seems a good connection, The only port listed as available is “/dev/cu.Bluetooth-Incoming-Port”, so that is what we select.

Compiling the example script (serial,begin and serial.print) fails to compile "Arduino: 1.8.13 (Mac OS X), Board: “Ringo by CircuitMess, Minimal SPIFFS (Large APPS with OTA), 80MHz, 921600, None”

cc1plus: internal compiler error: Illegal instruction: 4
libbacktrace could not find executable to open
Please submit a full bug report,
with preprocessed source if appropriate.
See for instructions.
exit status 1
Error compiling for board Ringo by CircuitMess.

Trying to burn the bootloader to I/O Board also fails:
Arduino: 1.8.13 (Mac OS X), Board: “Ringo by CircuitMess, Minimal SPIFFS (Large APPS with OTA), 80MHz, 921600, None” v2.6
Serial port /dev/cu.Bluetooth-Incoming-Port
Connecting……____Error while burning bootloader.

A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header

Finally, Circuitblocks reports: Upload error. Check your ringo and try again" whir the restore Ringo Firmware button and when checking the example ‘hello’ sketch reports the ringo as disconnected.

So it seems I cannot upload firmware over-air and cannot connect Ringo to my Mac (OS 10.11.6) currently. Ay advice or suggestions very welcome since I would like to try and write some apps.


Okay so a brief update for any other Mac users (are there any?)
I have managed to upload firmware 1.0.2 via a different Mac running 10.14.

However the over-air firmware update 1.0.5 still fails – can someone at Circuitmess verify that the 1.0.5 package is valid and correct?

For any other Mac users facing the same frustration, it appears that drivers are needed to connect to Ringo in addition to everything in the online guide. Even with 10.14 where I had a cu.URT1 port it did not work.

I downloaded the USB to UART Bridge VCP drivers from here,

After installing these a new port was available in Arduino SLAB_USBtoUART and this one worked. There are legacy drivers I will set-up on my son’s older machine but I wanted to update this thread for any other Mac users with the same issue.

Hey there,

Thanks for supporting the project!

Macs have a history of USB ports not being compatible with many different devices and this topic has been covered on this forum a lot. Apple even issued an article on these things and possible fixes that can be used.

Unfortunately since we don’t own more than one Mac in our little company (everything is Windoes/Linux based) we don’t really have any information which devices have and which don’t have these issues. Most of the Macs function properly and our customers have had no problems with it, but for others it’s not the case.

You can maybe try a different WiFi network (like a mobile hotspot) for downloading new firmware over your phone - that could fix the problem. Also, when uploading via Arduino IDE, try to press the little reset button on the side of the phone when starting the upload, and press it several times in succession. That could help fix the problem.

The OTA updates work just fine, we even have 1.0.6 one.

Stay in touch,

Hi Robert,
Maybe I was just unlucky then that neither of my Macs had the necessary drivers and hopefully any other customer with the same problem will find my post with the driver link.

I just tried the OTA update and still see 1.0.5. Unfortunately I do not have easy access to another WiFi network so will make do with the Arduino updates which work with the SLAB drivers.


1 Like