Nibble was functioning but no longer

I have a nibble, and I have just finished building it. It has been functioning properly for a day, but now whenever I turn it on, the blue led blinks once, but nothing else happens. I tried re-soldering it but it still doesn’t work. This is my first time soldering, and being a noob, I soldered on the front instead of the back. Then I did solder on the back. Here are the pics of my nibble.

I took off the casing to re solder.

I tried to clean it up a bit more

Hey there @Tizzlerbot76,

please reach out to us at [email protected] so we could help you fix your Nibble.

Cheers,
Dora from the CM

Thankyou so much! I will

I would try resoldering the battery, screen and power switch first as they are what allows you to turn your nibble on.
From what it looks like, I think there may be a bridge perhaps on the screen (hard to tell with the shadow and blurriness)

Thanks for that!
I’ve taken better photos so you can see more clearly.
After I resoldered the display, the blue light is now permanently on (even though it’s really messy!). But still no display or

sound.

So there is most certainly bridging happening in the first picture. I’m not sure how you’d clean that up. Maybe some solder wick.

Your second pic looks ok, just try to move the wire for usb connection so it doesn’t touch the other pins.

So in conclusion I think it is your display soldering. Try to clean it up and it should hopefully work.