"NO BATTERY" message in some gamebuino games [solved]

Hello people,

I have assembled my makerbuino and started testing games. All the games included in the SD card work without a problem. But testing a couple of specific games in the gamebuino gallery lead to an increased screen contrast and a “NO BATTERY. PLEASE TURN OFF” message.

I am totally sure the battery is fully charged, since it has been charging over night. Also, I can play any other game included in the SD card without a problem for several minutes without getting that message.

The games having this problem (or at least the ones that had the problem with mine) are:

  • Copter Strike
  • Tetrino
  • Sokobuino
  • FX Synth

Others work without a problem:

  • Maze
  • Punkt
  • Shot Zero
  • Armageddon

Is there any compatibility issues with gamebuino games and makerbuino? Maybe I’m doing something wrong? Does this happen to anybody else?

Important: If you are going to try any of these games and get the message, you can exit to the menu by quickly pressing the C button after turning on the makerbuino (before the error message appears). Also, after doing so, the message “Flashing loader. Don’t turn off” appears. Do not turn off (I mixed one message with the other and thought I had to turn off). Doing so bricked my makerbuino and I had to use the programmer to upload a game in order to fix it :laughing:. Be careful :slight_smile:

Will keep researching :wink:

Have a nice day!

I think the makerbuino runs the gamerbuino software and games.

If you look in the source code for Makerbuino/GAMEbuino and some games there are options to turn the Battery level warning off.

Finally I have found the problem. It seems to be a compatibility issue with the games compiled with the old gamebuino library. It also happens to new revisions of the gamebuino.

Info found in http://gamebuino.com/forum/viewtopic.php?f=17&t=676

If you already use the latest version of the library (v0.2 from Sept, 13 2014) everything is fine. If you don’t, please re-compile your games and update the binaries (.HEX and .ELF) so the settings works properly. If you don’t the Gamebuino fall back on the default values, and it can cause problems especially with the contrast setting, which could make your game un-playable. Thanks!

So after compiling every game with the latest gamebuino library, every game seems to work (I had to front some problems, since some old code does not work with the new Arduino compiler, but it was worth :slight_smile:

1 Like

The charger board has two LED’s on it.
Red indicates that it is charging the battery.
Blue indicates that the charge cycle has completed.
Hope this helps.

1 Like

Thanks @Eddie, but as I told in the previous post, the error is not related with battery level (even though the message says so). The error is due to an incompatibility problem with games compiled with an old version of the gamebuino library. After downloading the code and compiling it with the newer version, it works without a problem.

By the way, anybody knows if there is a way to close a thread once the problem is fixed?

1 Like

Luke, can you make the compiled games available somewhere, so that others can just grab them and put them on an SD Card? Would help people on the thread a lot :slight_smile:

Hey @pilhuhn!

I made a Zip file with the 16 games I downloaded. I think there’s still one that doesn’t work, but can’t remember which.

In order to keep credit to the original creators, I included a TXT file with every game with the authors name and the original download link.

You can download the pack here: https://mega.nz/#!1Y9xlZ4Y!V31iQCoe1aRdbw9WLlsd2QM6daqzI9u4qVYu_VR_AMQ

1 Like

Hello, i just got/built a makerbuino, and have this problem aswell, this zipfile is unavailable now, do anyone still have it and can upload again?


@nilly, this is an old thread.
In order to fix this on your console, you need to go to the settings app and intimate the “checkup wizard”. Go through all the steps of the checkup wizard and it will set the needed EEPROM settings that will fix this

Thank you for your patience and keep me posted on your progress :slight_smile:

Hello, that doesn’t fix the issue I’m afraid. I’ll try compile the projects that has this issue with latest gamebuino library, but if I get any issues I wouldn’t know what to do about it code wise:/. Would like to learn some coding and make a game for buino.

@nilly, what projects are having this issue?

Can you please tell me when you’ve purchased your kit?

Please, do not recompile anything, I’ll help you make your MAKERbuino work.

Also, did you make sure to go through the hole checkup wizard?

One more thing - here is the latest MAKERbuino SD card image. Please try putting this on your SD card:

To late :slight_smile: I did compile the fx synth, and now it works without the battery warnings. Some other of the games also has this issue can’t remember wich. But recompiling with latest gamebuino library seems to fix the issue

Awesome, well done!

Where did you download the FXsynth from?
Can you please find out what other games had this issue and tell me where you downloaded them from?

Thank you for your help! :slight_smile: