No signal.. what am I doing wrong?

Thanks for the update.

I came to the conclusion last night that it wasn’t a hardware problem. I believe that the light signal means that it works. I don’t think it’s the phone specifically.
I decided to pay a visit to my local tower this afternoon. I got ‘25’ which doubled the usual signal. While driving around, the signal gradually lowered, but I could not make one call.
I think that leaves only two problems left on our list. It is either too low to make a call, or it is TMobile - unable to accept a 4G signal from a weak Arduino. I can’t remember hearing a success story from the 4G-Tmobile crowd. I can recall a few 2G success stories for our young boy, Ringo.

I am not discontent with Ringo. My overall interest is to access the controller. I am looking forward to such a device like Ringo without a phone in the future. My father wanted me to have a phone to call him. That’s why this interests me.

Thanks everyone for trying. We will eventually solve this.

I have a 4G board headed my way from Croatia. It’s made it as far as Queens, NY, but is still on a slowboat within the USPS. When I get it, I plan to test it with Ting/T-Mobile (attempting 4G connection at 700MHz Band 12), and perhaps with Verizon (I have an inactive SIM card, but at least I would think it would connect me to Verizon plan sales to try to set up the card.)

What I’m afraid of is that the 4G board will connect with Ting/T-Mobile via weak/overloaded GSM (2G) and will not try to do VoLTE on the 4G Band 12 signal; and I’m also afraid it will fail miserably with Verizon (even though it will show a strong 4G signal) because it won’t try to do VoLTE and will be unable to fall back to CDMA (2G) because the module cannot do CDMA. I’m certainly hoping (since Albert says the 4G card has been tested in the USA with Verizon) that neither of these negative outcomes occurs, but rather in both cases the call goes through using VoLTE. If it does, then your problems are unexplained; if it doesn’t then I’ll be in the same boat as you folks…

Time will tell - maybe a couple more days and it will be in my hands.

1 Like

Ting told me that the company will not support 4G because TMobile won’t let them. I don’t know if that’s just my area or a miscommunication. I’d like to know if you ever get 4G with your Ringo.
I don’t use Verizon because they don’t support GSM…? That’s why I haven’t switched over. I’ll look into it tomorrow and get back to everyone if I can get some GSM out of them.

You’ll never get GSM out of Verizon, only CDMA (2G/3G) and LTE (4G). That’s why if it works with Verizon, it must be using 4G and VoLTE. Albert says it’s been tested with Verizon in the USA and it works. I’m anxious to see if that’s really the case. Verizon SIM cards are for 4G only; CDMA phones do not use a SIM card - the account is married to the phone itself.

1 Like

If Ting won’t support 4G, then Ting really sold Circuitmess a bill-of-goods!!

Fortunately, I also have a genuine T-Mobile SIM card I can try 4G with. It’s not activated but does connect to T-Mobile sales.

1 Like

I’m so confused… As long as it works lol

A lot of people ( the vast majority) have had no problems connecting to various network carriers around the USA, the stories you read here are mainly from the ones that have troubles.

We’ve shipped out over a thousand phones to the USA and there is a pattern of the phones working just like intended. Of course, that depends on many things, one of them being the area, since the USA is very inconsistent when it comes to signal, especially 2G.

Since there are a lot of carriers and types of networks, not to mention different frequencies on which they work, some of them will cause more issues than others. That’s why we’re very grateful for your help and research - every little thing all of you do helps us determine which networks work the best and which not.

@frankprindle any updates on your board? Did you get it?

1 Like

It is supposed to arrive in today’s mail late this afternoon. I’m very anxious to test!

2 Likes

Mine is 4G and Tmobile just isn’t doing well supporting me
:unamused: chews gum

My 4G package arrived yesterday. The quirky/goofy 4G module I had sent back had been replaced by a SIM7600A for the USA. It is no longer quirky, and after considerable experimentation, I think the secret is revealed. Read on…

The 2G module supports only GSM, and T-Mobile/Ting’s GSM service is terrible in my area. This particular 4G module (SIM7600A) does not even support GSM; however it does support LTE and (as I have now learned) UMTS (AKA WCDMA, a successor to GSM). T-Mobile/Ting supports GSM (poorly), LTE, and UMTS. Their UMTS signal is Band 2 (1900MHz) just like their GSM signal, but is somewhat stronger and does penetrate all but one room of my house (you can key in your address on the Ting coverage map and see exactly what modes are offered where you are.) Furthermore, just about anywhere other than my house the UTMS signal is very strong. So there definitly is an improvement, but it has nothing whatever to do with LTE.

What I did find is that if I forced the SIM7600A to LTE only mode, it would not acquire a signal from T-Mobile/Ting even though they utilize LTE bands 2 and 12 extensively and I’m sure the signals are there. I take this to mean that VoLTE is not supported by the SIM7600A (its documentation has virtually no info on VoLTE.) I could not get a Verizon SIM card to work in any way, shape, or form, so I’m assuming they don’t support UMTS.

How did I discover this? (you may ask)… it turns out if you follow the settings menu to the “SIM Module debug” option (you can skip the List Operators) and plug your phone into a computer running Arduino IDE (and set the port right), you can open the Serial Monitor and type in commands to the SIM7600A (with line ending set to Carriage return).

The command AT+CNSMOD? requests the current cellular mode. With the Ting card connected to the network, I get a response of +CNSMOD: 0,4, which means it’s connected UMTS/WCDMA. If I’m not connected to the network, the response is +CNSMOD: 0,0 which means disconnected. If the second number were 8, it would mean connected via LTE, but that never happens.

The command AT+CNMP=14 sets the SIM7600A to connect with UMTS/WCDMA only; That works fine. The command AT+CNMP=38 sets the SIM7600A to connect with LTE only; That never results in a connection until I send AT+CNMP=14 again or AT+CNMP=2 (automatic).

So the bottom line: my point is that VoLTE just doesn’t work at all and it appears that Verizon (offering CDMA and LTE only) doesn’t work (the SIM7600A does not support CDMA). But if you stick with T-Mobile/Ting you should get reasonable reception over UMTS which is selected automatically by the SIM7600A, at least here where I live in southeastern Pennsylvania. I can’t explain the rumors of folks in the USA using Verizon successfully, but I’d be interested in what reply they would get if they sent the AT+CNSMOD? command.

In fact, if everyone who reads this should try sending that command and reporting back here what the reply is, we could expand the knowledge base regarding this issue greatly.

For reference, these two commands, and hundreds of others can be found in this document:
https://simcom.ee/documents/SIM7600C/SIM7500_SIM7600%20Series_AT%20Command%20Manual_V1.01.pdf

One last thought regarding VoLTE. Although it’s virtually undocumented in the SIM7600A documentation, there are smatterings of information on the internet that seem to imply that VoLTE does exist on this chip but needs to be enabled by some hocus-pocus burning of something undocumented to the chip. All very strange.

2 Likes

Hey Frank,

Thanks for the abundance of info here.

I agree that VoLTE was poorly documented on the chip, but we’ve been able to use it with the European version of the chip.

As for the US, I have had a friend test the module with a Verizon SIM card and it worked. I’ll try to gather more info on this and get back.

Thanks for the effort, we’ll look into making the phone supported by more carriers worldwide in the future.

Keep me posted on your findings

Cheers!

1 Like

Yes, Albert, if you could have your friend with the Verizon SIM card send the query AT+CNSMOD? in “SIM Module debug” mode and report the mode (2nd integer in the reply), that would reveal another secret.

We would all appreciate it, I’m sure, if anyone who is successfully using this phone with a Verizon SIM card could let us know the reported mode. I’m just worried that anyone who’s phone is working fine isn’t even going to read this :frowning_face:

1 Like

Albert, you should probably notify US Ringo owners that Ting is moving to Verizon in March. Maybe not include their SIM in new kits.

1 Like

I want everyone to know that I should be travelling for Christmas. I will try Baltimore MD and when I’m in New Jersey. I’ll record and update everyone on the numbers on New Years EST-NY (when I’m back).

Edit - Still using Tmobile

I HAVE GRAND NEWS, everyone!
My SMS miraculously activated today!!
I was attending a local market event, and I started hearing beeping. I took my Ringo out, and the Ringo was flooded with text messages :smiley:
My father was about to drive home. I ran up to the car and knocked on his window. I showed him the screen. He said “send me a text”. I quickly added his contact and pressed 4 for ‘hi’. He put his phone in front of me, and at the top, an iOS message box showed ‘hi’ :slight_smile:

I want to thank Albert for making his dreams come true :joy:
Thanks to everyone for sticking with me in these hard rural areas.
I’ll update everyone the same day that I can make my first phone call.

1 Like

@kfixman, I’ve been talking with Ting about this.
Ting is not “moving” to Verizon, they are just expanding to Verizon.
Meaning that they will continue using both grids and will allow users to connect to the network their device is compatible with.

@8bitRobot this is some great news, keep us updated :slight_smile:

2 Likes

I will be updating everyone on a new antenna mod soon.

@albertgajsak I need to get in touch about my USB port. One prong came out today. I can’t seem to find a picture or schematic that explains what’s what. It’s being super difficult. I’m running through different ideas, but my plan B failed.
(I can solder.)
There used to be a light for power when charging? That won’t turn on anymore.

I have a bad camera.

Place this radio antenna on the screw by the Ringo antenna.
Then place the wire in the upper screw hole. If you’re getting Signal: 4 - You should see 5-10. If you got 10 before, you should get around 25-30.
The length of the antenna makes little difference-stay within range. Try to point it toward your signal.

Hey, it seems that the USB charging port has de-attached.

You can try to solder it yourself, it shouldn’t be too hard. It’s a very tight part of the phone there, but the port itself is soldered from above so all you would have to do is to clear the hole and re-solder it so it fits again properly.

Great stuff for the antenna!! :smiley:

1 Like

I tried that. It’s not working well.


OKAY…I was resoldering again. A part of the problem was the crappy engineer who made USB Micro B. That guy needs to lose his pension.
I placed a piece of wood under the port to tighten the cable. This time the solder is touching. The light is on and I checked the lock screen.
For future reference, the port should excess the hole like a normal I/O pin. The idea that it is literally scratching the surface in practice is both unappealing and ludicrous on an engineer stance. Now I have to jam wood into my phone 2 times a day to keep everything touching. That’s soviet… :sweat: :joy: