Not Calling Or Connecting To Network?

I just recently received a pre-assembled MAKERphone as part of my Kickstarter reward, and I’ve inserted a working SIM card from another phone. I’ve been able to receive a firmware update via my home Wifi network, but beyond that, I haven’t been able to call numbers, text numbers, or connect to my Wifi (the signal strength is always apparently 0). I’ve tried this with multiple SIM cards from multiple phones that are on my MetroPCS plan, but no luck.

Can anyone help me with this?

I have a similar problem, although mine does connect to wifi. All the tests passed update worked, sim module debug doesn’t error (although I am not sure how to use it). However it doesn’t get dial tone. Before the update it would error saying “Cannot Connect to Network” but now I just says dialing for a long time. I tested the Sim card in another phone and it works fine. It got me thinking: I live in Montana USA and it seemed to have limited frequencies when it comes to 4G. I started googling around to see if I could find out more info. I did find a similar module to the one that was included in my phone. However the one I found is SIM7600A-H meant for north america. Not sure if this is a rabbit hole?

What (if not SIM7600A-H) module was included with your phone? I am in Pennsylvania but have a SIM7600SA-H and am having similar (though not identical) issues.

no “-H” it is just a SIM7600A. I saw some data about what frequencies are used where and with what carrier for 4G in the us… not finding it right now though. Also because mine is not a “-H” I am having trouble finding what frequencies it supports also. The modules available that I can find are specific to a particular area like North America, Europe or China. I thought the “-H” meant North America, but I see it on EU modules too, so maybe just a red haring.

Now when I try to dial I see “Registring to Network…Network unavailable, Try again later.”

1 Like

Are you sure you don’t have a SIM7600A-H? The -H is rather small and slightly below the A on the module.

I don’t think there is such a module by Simcom as SIM7600A (without the -H).

If you have the SIM7600A-H, it supports 3 LTE bands: 2, 4, and 12. These correspond to frequencies 1900MHz, 1700MHz/2100MHz AWS, and 700MHz. These bands are widely supported by T-Mobile, somewhat less by other carriers. See https://www.signalbooster.com/pages/what-are-the-cellular-frequencies-of-cell-phone-carriers-in-usa-canada

@JWinslow23 Hey, sorry to hear that, we will work the problem out.

The most common problem is the one that the SIM card is not properly inserted - see the photo and check out if you did it like that. When the SIM card is inserted, the phone must be restarted so that the SIM module reads the card.

Wi-Fi network is not connected at all times since it currently has no other functionalities other than updating firmware (we will add some more features in the future). The signal strength is actually meant for the network, not for the Wi-Fi, so it is logical that it’s zero since you have no connection to the network.

US supports several modules, but there is some chance that some frequencies are not as strong in some areas. There is limited data on these things and we’re sending modules that are supported in most areas and that work the best in most of the country.

Did you find some additional info about the frequencies? If we determine that some other module would work better in your area, we can arrange a module switch.

Cheers,
Robert

1 Like

ya, it took me a moment to accept the ‘backwards’ SIM slot, but I got that early on. About the “-H” I understand what you are saying, @frankprindle, that it is usually on the second line. Mine does not have any second line. Maybe that means it is cooler and does more generic things? but at this point I am unsure. I may need to stop by the TMO shop today and find out what band LTE we have locally.

I wonder if there is a way to get signal strength?

I guess generally speaking I don’t see any failures or errors unless I try to call or text.

@robertCM, I would be willing to buy another module to try. Are all the mPCIe modules compatible? or just specific ones like SimCom?

I am inserting the SIM card the right way, but with my MetroPCS SIM cards (which are already part of a phone plan) a Wifi connection won’t even register, which seems necessary for making calls with the MAKERphone. The included Ting SIM card (as of yet unactivated) does allow the connection to work and calls to be made, though because it’s unactivated it will only call Ting customer service.

I live near Milwaukee, Wisconsin. I don’t know how to find out which frequencies are supported by MetroPCS in my area, but I’ll try my best to get that information for myself.

FYI.

I live in South Korea.
My Ringo has SIM7600E.
It’s spec sheet : https://simcom.ee/modules/lte/sim7600e/

  • TDD-LTE B38/B40/B41
  • FDD-LTE B1/B3/B5/B7/B8/B20
  • WCDMA/HSDPA/HSPA+ B1/B5/B8
  • GSM/GPRS/EDGE 900/1800 MHz

I checked that WCDMA B1(2100MHz) worked well (calling works!) in South Korea.
But LTE didn’t work. (Registering failed)
I’m not sure where is the problem, carrier or Ringo.

Anyway Very interesting product!

@canterburyice The SIM module we’ve sent you should work fine in your area - it was all tested and researched for that one to be the best module. The problem most likely lies in something else. You can try other modules if you want, but we can’t guarantee you it will work.

@JWinslow23 what do you mean by “Wifi connection won’t register”? It doesn’t have anything to do with the phone calls. If you mean the cellular data, that also should have no connection to you making a phone call.

Most of the time when I try to make a call with any of my own MetroPCS SIM cards in the MAKERphone, it says that it’s “Registering to network…”, and after a few seconds, it says that the connection failed and that I should try again later, after which it brings me back to the phone number entry screen.
On the rare occasions where it does not say this message and lets me through, the call never goes through on the other phone, and the MAKERphone is stuck at the call screen even after minutes of waiting, without any visual indication that a call is being made.
I don’t know what the Wifi has to do with calling either, but I don’t know a way not to infer that there is some connection there (no pun intended).

Please send me a few images of the back of the phone (remove the casing and take a picture of the SIM module, speaker connector, and general open back).

We’re going to check out if the solder joints and connections are good so we’ll move on from there.

Thanks in advance and sorry for the troubles,
Robert

Same problem here in Australia on 4G, tried a Vodaphone and Telstra working SIMs with same result, updated firmware over WiFi still no go? Reset phone several times with same result.
No dial tone etc

Sorry for the issues jack,

I would like to ask you the same - please take some photos and send them to me.

Thanks,
Robert

Thanks Robert,

Leave it with me.

Jack.

@jack can you please elaborate on what the “same problems here” actually are?

Feel free to send this to contact@circuitmess.com

when I was taking pics, I decided to take a close up of the socket solder joints and I see a bunch of solder bridges.

Pins 41 and 39 are both VSIM, so that bridge is legit.
Pins 37, 35, and 33 are all GND, so that bridge is legit.
Pins 29 and 27 are both GND, so that bridge is legit.
These bridges are present on the 4G main board and absent on the 2G main board. My theory is that the 4G module consumes more power supply current and the bridges have something to do with that.

This has been covered previously in the topic Solder bridge on network socket. The upshot is that “it’s ok”!

2 Likes

ok cool… does this mean we can only use 2G boards as it stands?

!
here are some other shots