Not Calling Or Connecting To Network?

Thanks Robert,

Leave it with me.

Jack.

@jack can you please elaborate on what the “same problems here” actually are?

Feel free to send this to [email protected]

when I was taking pics, I decided to take a close up of the socket solder joints and I see a bunch of solder bridges.

Pins 41 and 39 are both VSIM, so that bridge is legit.
Pins 37, 35, and 33 are all GND, so that bridge is legit.
Pins 29 and 27 are both GND, so that bridge is legit.
These bridges are present on the 4G main board and absent on the 2G main board. My theory is that the 4G module consumes more power supply current and the bridges have something to do with that.

This has been covered previously in the topic Solder bridge on network socket. The upshot is that “it’s ok”!

2 Likes

ok cool… does this mean we can only use 2G boards as it stands?

!
here are some other shots

I’m not sure I understand your question. You’ve shown a 4G main board with a 4G module, so all is copasetic.

Pretty much everything seems to be soldered well, at least those that are important for calling.

I see you are using a Ting card - did you activate it before starting to use it?

Also, did you try any different SIM cards and went maybe to some other areas (just around the place you live where maybe the signal is better)?

2G boards can be used only with the 2G modules, while 4G boards can be used only with the 4G modules.

Robert

Another data point: I get the “cannot register with network” error when trying to dial from my house, but when I went to a different part of town the next day and was showing my friend how it didn’t work, it suddenly worked & I was able to dial out.

I think I may have stuck my antenna on badly, as the cable kind of runs into the case with where I have placed it. Would it be safe to carefully pull and re-stick lower, or should I just leave it do you think? Also, when placing it in the case, the antenna cable kind of loops over itself. Would this be likely to cause crosstalk interference problems?

alphamule, is your a 2G or 4G network card? Are you in the USA? If 2G and in the USA, this symptom is typical of the T-Mobile 2G network, which is just terrible.

The antenna cable is shielded coax and I doubt it’s positioning will have any effect on anything. I wouldn’t pull anything off - my experience with the adhesive on the battery is that once stuck, it’s on for life; so you’d most likely just tear the antenna trying to get it off.

If you have a 4G module or are not in the USA, this symptom may be a lot harder to explain. Check the coverage map for the carrier you are using for reception exactly at the address of your house; you may just be in a dead zone for that carrier.

I have a 4G one and am in the US. I also use Ting with my normal phone and can get reception at the house, but the signal isn’t super strong (2-3 bars).

Hrm. Is it possible to buy a replacement antenna somewhere (or better antenna, even) and attach it to the module after desoldering the original in case I screw it up?

The antenna is not soldered to the module, it’s attached with a coaxial snap-on connector. You just pull it off like a 9V battery connector.

heh, if by ‘copasetic’ you mean “not working”, yes I agree. I was wondering if, to just make it work, I need to get a different board. it sounds like there are still power issues?

I have 2 LET phones that are active, I can take the Ting card and put it in them and make calls. I can take the SIM cards from the working phones and put them in Ringo and no go.

Don’t take my being silly as giving up. I am willing to do whatever to troubleshoot. Is there info I can gather from my cellphone to find out more?

Right, SIM card is fine, can make calls from a different phone, tried ATT and TMO cards in this phone and all do the same.

I don’t follow you through the 4G/2G module/board statement. Do you mean the main PCB is different between 4G and 2G? That it would have to be different kit? That the phone module isn’t able to be just swapped out? I guess that would make sense.

The antenna question from @alphamule is an interesting one. I thought I had mine on the wrong one at some point. The instructions don’t say where it should be, although it came attached, I took it off to make it easier to stick on the case. Swapping it between AUX and Main didn’t make a difference for me.

The antenna goes on the coax connector closest to the top of the phone.

Hey Jack,
Did you get this sorted out mate?
I am from the great land down under too, and I have not had any issues with using an optus or an amayasim sims.

Lindsay

No Lindsay, have to document my process and send to Robert, might
Get a go at it in a few days:-)

Cheers,

Jack.

1 Like

@alphamule Yes, just like Frank said, the cable shouldn’t cause interference, but the sticker placement just might (although not too much). There is a really slim chance you would get anything by peeling the sticker off and putting it on again, but the possibility of damaging it would be really high, so that is not recommended. The alternatives are really unknown - we haven’t tested them. You can try it if you want to but at your own risk. If you mess something up about the antenna, we can always send you a new one for a small fee + shipping. The antenna is supposed to go into the little cutout next to the battery, it should fit just about perfectly.

@canterburyice Yes, that is right, the 2G and 4G modules use different boards, so just swapping the modules is not going to work. The network coverage is odd, especially in the US, where in some areas there is an excellent network and in others it really isn’t, all while using same modules.

I cannot really help you with testing of the device since we’re so far aways from there (Croatia is over 4000 miles away from NY :frowning: ), but I can assist you in any way possible from here!

Hopefully we will work through this problem together and find out why is that signal so weak in some places.
Cheers,
Robert

@robertCM, good to know about the research, I appreciate that.

So I found that the antenna was connected to the wrong post. It needs to be attached to the post nearest the top of the phone. I swear it come on the wrong post, but I cant be 100%. Either way, I changed it and then checked for updates. The phone did not find any updates, it rebooted and then I noticed the triangle did not have an X as one of the other posts mentioned and I was in the middle of writing another post and decided to try a call and it started ringing. So that is good. I did have an issue now where the settings like silent menu navigation did not get applied on first boot, only after I went into the preferences and hit save.

But I am calling now… and I am very happy. :slight_smile:

2 Likes

Great that works!

Don’t know how that happened, it could be our mistake - we’re also humans and it sometimes happen!

Glad that you could manage to work it out. :slight_smile:
Keep in touch if there are any other issues.

Cheers,
Robert