Phone indicates it is calling, but no sound and the call does not go through

My 4G phone has a couple of problems. Although it passes all tests. When I dial a number (using Ting), it indicates that it is calling the number but can’t hear ringing and the call does not go through. I have checked the antenna wiring and it is good.

I don’t know if it is related, but I can’t update the phones firmware. The phone finds my network, accepts my password and It downloads the software for about 30 seconds and then says “error while downloading” and reverts to the old firmware version. I have tried a new sd card.

Any help much appreciated.

Hey,

Thank you for supporting the project!

Did you activate your Ting card first? If you’re using the ones we’ve sent you, you have to activate it in order to work.

Also, do you have the sound on your phone when not calling?

Cheers,
Robert

Thanks so much for responding Robert. I do indeed have sound for everything else on the phone, and did activate the Ting sim on line. Even called them for some troubleshooting. They let me cancel the sim when I couldn’t get it to work.

As far as uploading the new firmware, I have used the Arduino IDE but I am not knowledgeable enough to figure out the procedure for the update. Really don’t want to brick the phone.

Thanks, again,

Kent

Hey Kent,

Can you try some other SIM card maybe, just to see if the problem was of that nature?

You can download our own software CircuitBlocks where that process is really easy - just a simple push of a button!

Robert

Thanks Robert. I tried the T-Mobile chip out of my iPhone with negative results. The Ringo recognizes the sim and even shows signal strength. It shows that the call is being made, but then no ring sound and the call does not go through.

Is there a tutorial on CircuitBlocks for us dummies?

Hmm, that’s odd. There is a chance that the DTR pin on the brain board is not connected properly and that may cause the phone not to wake up the SIM module when calling. Please send me photos of the brain board and its connections so we can check if everything is cool there.

Also, did you try receiving the calls from somebody?

Yes, of course there is, here you go: www.circuitmess.com/circuitblocks-tutorial/ :smiley:

Cheers,
Robert

Robert, the forum doesn’t like my iPhone picture .extensions, and rather than convert them, I will send them to you by pm.

Decided to convert and put pictures on the Forum.

I was finally able to download the latest Ringo firmware (thanks to Robert), and decided to try the phone application again. I still can’t make a call - no sound, but the phone indicates that a call is being made. The SIM is recognized, and I have signal strength. I also can’t receive a call, it just goes straight to voice mail without ringing the Ringo.
If we can fix this one Robert, my phone will be fully functional.

How many bars are showing in the signal strength indicator (triangle) on the home screen? The triangle doesn’t have an X next to it, does it?

Assuming you have reasonable signal strength, if you try to call another phone that is in your possession, does that phone ring, and if you answer it, does the Ringo show the call in progress (timer)? It could just be a speaker issue…

I get a couple of bars, which is all I ever get inside (T-mobile). The speaker works great for all other apps.

The phone shows that the call is being made (calling #), but no sound of ringing, and it will just stay on the calling screen until I end the call.

When I call the Ringo, the phone does not ring, and the call goes straight to voicemail.

What I was asking was: does the phone you are calling ring?

Incidentally, there are separate electrical paths from the audio board to the speaker and from the network module to the speaker, so other sounds could work yet the network sounds (ringing or voice) might not.

No the called phone does not ring, and the Ringo, when called does not ring.

Well, I’m out of ideas… it now all goes back to Robert’s original theory that the brain board is not having the proper conversation with the network board to initiate a call or intercept an incoming call. Yet there is obviously some communication there in order for the signal strength indicator to be updated from the network module. Sorry, I’ll turn it back to Robert at this point.

Thanks much for you help Frank.

Update. I tried my neighbors Verizon SIM in the Ringo, and it would not load it. Unfortunately it will no longer load the T-Mobile SIM from my iPhone. Sigh!

Robert, did you get my DM?

1 Like

@kfixman Yes, Kent. The time difference is killing us, even we have to sleep at night and unfortunately that is when you guys are active the most! :sweat_smile:

We’ll fix this, don’t worry. You have a reply. :slight_smile:

Robert

I think I have done all that I can. I have re-inserted the SIM many times, and reset the phone many times. As you can see from the pictures, the display shows “loading,” and that is as far as it gets. In the past it did load the SIM, gave me a signa! strength of 2 on the Network display, showed that the call was being made, but no ringing and no call. Here is a picture of the SIM module that you requested Robert. IMG_0059|375x500

Here is the picture of the SIM module that didn’t come through.

I’m actually having exactly the same issue, so it’s nice to know it’s not just my phone.

1 Like