Phone won't complete new firmware update

Looks like my network is accepted, and then it tells me that a new firmware update is available. I start the down load and it looks good for awhile then it says update failed. All other features of he of the phone test good. Any help appreciated


Thanks for supporting this project!

Can you please try some other Wi-Fi network or a different SD card (if you have one)? This really shouldn’t happen.

If it doesn’t work, you can always use CircuitBlocks or Arduino IDE to update the firmware. :smile:


This is interesting. I got the CircuitBlock IDE. clicked on the Restore Ringo firmware and all I could get was “Upload error. Checks your Ringo and try again.” Am I in the right place?

Yes, that should be the right place.

Are you sure your phone is properly connected to the computer?
Have you tried changing cable or USB port?


kfixman, if you are using Windows and have Python (and its serial library) installed (I’m assuming CircuitBlocks must install that if you didn’t have it previously installed), then maybe you can try the following, just to get back to basics:

Download this zip file and extract all 6 files into the same directory: Flash Firmware Turn on your phone and plug its USB into your computer. Look in Device Manager to see what COM port was assigned to “Silicon Labs CP210x USB to UART Bridge”. Edit the batch script flash.bat and change “COM6” to the COM port assigned by your computer to the phone. Now just launch (double click on) flash.bat and your phone should be updated to firmware version 1.0.1.

This is the method I always use to flash new firmware, and it always seems to work without a hitch. Rest assured there is nothing nefarious in the zip file, but feel free to virus-scan it if you like.

If you’re not using Windows, sorry this will not work. If you don’t have Python installed, well that’s quite an exercise in itself, but I’m hoping CircuitBlocks did it for you. I suspect the Arduino IDE board Ringo by CircuitMess also installs Python.

1 Like

Got it Robert. I used the same port that I used for the Arduino IDE, but at your suggestion, I tried a different USB port and it worked. I am up to date with the firmware, but still can’t make a call. See my other thread.

Thanks again.

1 Like

Whoops, looks like you beat me to finding a fix to the firmware update issue!

Frank, thanks for the info. Now I just hope to be able to make a call.