Platformio firmware compilation error

This happens every time i try to compile Ringo firmware.

src/phoneApp.cpp: In function ‘void phoneApp()’:
src/phoneApp.cpp:28:24: error: array must be initialized with a brace-enclosed initializer
String tempBuff[50] = “”;
*** [.pio\build\lolin32\src\phoneApp.cpp.o] Error 1

What should i do?

1 Like

Hey @Lukatoni,

thank you for reaching out.

Can you let me know if your Ringo is working other than that? Also, it would be helpful if you’d send us a few photos of the device (back and front, without the casing). You can send us the photos at

Looking forward to your reply,

1 Like

thank you for the reply.

My Ringo is working fine I managed to put and take apps of it, I followed the guide, but I can’t compile the firmware in VS code because it gives me that error and I don’t know how to fix it.

Hi @Lukatoni,

thank you for your reply.

Please try restoring the firmware again so the error occurs again, then go back to the home page in CircuitBlocks, scroll to the bottom, and in the footer, you will find a “Send error report” button.

Clicking it will open a window showing all the information which will be sent, which includes the error that happened as well as some other info about your system that might help us resolve your problem.

When you click “Send report”, the report will be sent to tour servers, and you will get a report ID. Please get back to us with that ID and we’ll be able to assist further.

Best regards,

thank you for your reply.

But I am not using CircuitBlocks. I’m using Visual Studio code as I am tryng to customize the ringo firmware.

Every time I try to compile the firmware without changing it I get the mentioned error. I followed this guide (Circuitmess Resources)

Hey @Lukatoni,

I’m Emil from the software department.

To fix this try changing this line in your platformio.ini file:

platform = espressif32

to this:

platform = espressif32@1.12.1

PlatformIO downloads the newest esp32 core, and it seems there are some backwards compatibility issues with our code since it’s almost 3 years old. A quick workaround is to use an older version of the esp32 core and 1.12.1 seems to work fine.

Hope this helps!

It worked!

Thank you.

I ran into the same issue earlier, it’s one of the most recent updates that breaks compatibility. Even espressif32@3.5.0 works ok for me, but not later.