Spenser using USB 3.0

hi!

Is there a way to connect Spencer using a usb 3.0 port? I just can’t configure it

Thanks,

Jose

Dear @Josito Spencer should work without any problems using a USB3 port. Are you experiencing issues using a USB port on your computer? What is the exact problem you’re having?

Dora from the CM

I tried in 2 different computes with windows 10 and they can’t recognize the device connected through USB.

I tried to update the drivers but windows says they are up to date.

As a result i can’t see Spencer using circuitblocks or the arduino program.

I read in the guide that also other people had had the same problem. “Some users have reported that Spencer’s settings don’t work when Spencer is plugged into a USB3.0 port, so if you’re having issues configuring Spencer, please try plugging him into a USB2.0 port.” but I do not have USB 2.0 ports.

Is there something I can do?

Thank you for your help.

Jose

This is not Spencer specific but I found that using USB-TTL adapters on USB 3.0 is a hit or miss. Even though drivers are installed when port is open it just doesn’t communicate.

The fix is connecting it to 2.0 port and then it all starts working as expected.

USB 3.0 should be backwards compatible but there are inconsistencies as we can see.

What kind of PC do you have? I find it odd that there aren’t any 2.0 ports available… Is it a Laptop?

What you can try is connect it through a USB (powered) hub. I haven’t personally tried it but some forums on the Internet suggest that it should work.

Hi, thank you for your help. I tried with two laptops without success. I solved the problem using a monitor with 2.0 usb ports.

1 Like