Stuck on the first steps of nibble coding

Hello!

I’m trying to learn how to code with the nibble and I’m already stuck on the first step. I put the blocks into the Arduino loop and I get a compile error. Looking at the example code and my code, I see some differences that aren’t in mine. I was wondering if I need to enable something or if I’m doing something wrong?!

code comparison|690x209

I think the example code uses the earlier version of the libs. As long as CurcuitBlocks blocks are the same there is nothing to worry about.

What is the exact error that you get?

Sorry, I’ve finally gotten back to my laptop and I’ve taken a screenshot of the error.
compile error|690x343

Update:
I tried it on my home computer and it worked perfectly fine. For some reason whenever I try any sort of code on my work laptop, it comes up with a compile error.

You might have some policy which prevents running certain programs I’m assuming since it’s your work laptop

That is most likely the answer, considering I had to switch networks to download circuitblocks in the first place.

Hi, I am glad that the code is working on your home computer.
If you need any further help with that, feel free to contact us via [email protected]

About the tutorial screenshots - they are indeed different than the code generated in the latest version of CircuitBlocks. We’re working on updating the tutorials as we speak, thank you for your patience