Wheelson display not working

HI! I assembled the Wheelson and it came to life! Yay! After a few minutes the display stopped working. Boo.

The battery is full charged. I have tried pressing and holding the reset switch up to 20 seconds and nothing magical happens. Tried disconnecting the battery for up to 20 seconds and no joy.

The display does a flash in the upper left corner and it kind of fades from upper left towards the middle of the screen (but never goes beyond the upper left quadrant of the screen).

It flashes about once a second.

And, I noticed there is a white LED on the bottom for the circuit board that also flashes white.

Can you help? Did I do something wrong (entirely possible as me trying to build delicate things is like the Hulk petting a kitten) (not likely a good outcome).

Thanks!

Ps love the kit and the assembly is quite elegant!

Hello there @sasquatch,

please send us a few photos of your Wheelson at [email protected] and we’ll be happy to help you out!

Thank you,
Dora from the CM