Wifi connection not staying

So this does not appear to work quite right and I can’t figure out why. I followed all the instructions. Installed Circuit blocks, set the temperature and wifi settings and regularly am told “I’m connected to a WiFi network but it does not have a working internet connection…” despite knowing that there is an internet connection and I verified that it is connected on the 2.4gHz band.

What’s the deal. I ask it one or two things and it stops working?

1 Like

Follow up observation:

Been going through the list of things that I can say/ask Spencer and have noticed that some just don’t work and then I get the wifi message. Though I can ask another, known to be succesful question, shortly after and it will work.

This leads me to believe that perhaps there is a timeout/fail element in play here. Whenever there is no response to the query within a specific timeframe the program presummes a timeout and plays the wifi error?

Hey devs, does this sound like I am in the right area?

1 Like

Hi @cadelle,

thank you for reaching out.

Sorry to hear you’re having problems with Spencer.

Can you try restoring its firmware?
You can do that by connecting the device to the PC, opening the CircuitBlocks app, and clicking on the restore firmware button.

Let me know if that helped.

Sincerely,
Monika from CircuitMess

Unable to restore firmware, shows “Upload error”. Tried on three different machines, Windows 10 desktop, Windows 10 Surface Pro, Ubuntu 18.04 laptop.

Tried compiling the heart sketch and it never does anything, just stays at half way compiling for several minutes and eventually I just close the program

1 Like

Hi @cadelle,

Thank you for sending the error ID.

I’ll forward this to our development team, and they’ll take a look and come back with an answer.

We’ll get back to you as soon as possible.

Sincerely,
Monika from CircuitMess

Hello!

Sorry to hear about the issue you’re experiencing. We haven’t encountered an issue like this before, where some commands work and some trigger an error, so I’ll have a few questions which will hopefully help us resolve the problem.

Which commands did you notice work and which don’t?
What is the model of the router Spencer is connected to?
Is your router running some sort of a firewall, and is this perhaps a school or company network which might have some network restrictions in place?
Which country are you located in? Some governments may block certain IP ranges, but since you say that some commands work, this probably isn’t the case here. Still, knowing where you’re geographically located might shed some insight into the problem.

Thanks,
Filip

I replied to the email I received…

The commands that work/don’t are random. Same one that works one time won’t the next. As I mentioned it seems like a time out issue with your server response.

The is my personal, home network, located in the USA. I can safely assume it’s not being blocked or else it would not work at all. What IP is SPENCER trying to access?

Why do you need to know my router hardware information?

Additionally I submitted another ticket. Spencer cannot run compiled code and failed when trying to update firmware. Tried on three different machines in Win 10 and Ubuntu 18.04

I am begining to think this is a lost cause… I didn’t realize I was purchasing that had to be connected to the internet in order to work. Internal network? sure. Have to call home to whatever country your servers are hosted in to answer “Tell me your name”. Not super thrilled about. Especially given the so for, spotty outcome.

I don’t think this is the right product for me and my family. How do i process a return?

1 Like

Hi @cadelle,

Thank you for your reply.

Is it okay with you to solve these issues via email so you can send us all the necessary stuff we need to receive to help you?

I’ve sent you an email with a few questions about the problems that keep on happening on your Spencer.

Feel free to ask if any question pops up.

Sincerely,
Monika from CircuitMess