Can no longer see games

Finally got Nibble assembled
RAn circuitblocks first demo to reset screen colour
Now I have a permanent Cyan screen and can’t see any games
Reset button does not restore
Menu button does nothing - at least I can only see cyan
Help! How can I restore defaults or undo code?

Incidentally I found the restore firmware option but that just gives Upload Error!

And, yes, I sent an error report ID 1775

Hey Mikel,

Albert here, the founder of CircuitMess.

We’re aware of the issue, and we’ll be publishing a new version of CircuitBlocks this week that will fix it.

I’m sorry you’re stuck with a cyan screen, and I understand this is not acceptable.

Thank you for your patience, and I apologize for the wait.

You can read more about it here:

Hey @Mikel,

CircuitBlocks is now available online at:

You can try restoring firmware now using the link above.

Let us know if the problem persists,

Managed to work out how to restore firmware
there is now no examples for coding nibble on the list only Chatter Armstrong batmobile and Batcontroller

1 Like

We are in the process of adding those.

You can check this guide to recreate those sketches and run them: Coding for beginners - how to code your Nibble | cmr-guide and more

Any news on restoring the code examples and games for Nibble?

1 Like

Hey @Mikel,

you can find both coding examples and restore firmware button here:

I think this is just one problem after another
The code says it needs micro python to install it wastes 10 minutes prentending to install it then says it’s not there
Tried resetting hardware and install again no good
Tried download agent installed that and circuit mess couldn’t find that either
Another afternoon wasted

hi, Albert here, the CEO of CircuitMess.

I am sorry you’re frustrated with your Nibble not working.

Please do not worry; we will help you make your device work.

Which browsers are you using?

Please use google chrome for the best experience.

If the firmware is not flashing, please send us a few photos or a video via

If needed, we will send you a replacement device for free.

Thank you for your patience

The device is flashing

It did connect and run the sample colour change program code before your changes. - then reset firmware stopped working. Then you fixed that and the models were removed

Now you have revamped the Circuitmess site and put in a requirement to install micropython and it goes through the motions but then can’t find it

I AM using Google chrome

As I said I have tried both ways of trying to execute the code neither can be located

Every time I try to do something with my grandson it doesn’t work

In summary:

The device was working up to the changes in that it loaded and executed code but at that time your reset firmware did not work, then you fixed that and removed the models, now you have restored those you seem to have introduced some other requirements that just don’t work

None of which seems to be documented

Initially we were unable to solder the circuit board mainly because the soldering iron supplied in two kits did not reach an adequate temperature

Now every attempt at running Circuitmess has failed

I am sure you initially invented a good product but the quality control is rather poor


Michael Trott

Sosob7 days ago you were going to help me with this
I explained that I am using Google Chrome which you recommend

The code just will not load

1 Like

Hey Mikel,

can you please send us an email to

Thank you in advance,

I don’t see that emailing is any different to posting here thanks
Best that everyone knows what
Is going on
I have replied to your boss’ email with details of my system and explaining that it is impossible to load the compiler or whatever it is you have added in
The fact is this used to work but since your changes it does not
Have you fixed it?

@Mikel hi,
Albert here from CircuitMess.

Unfrortunately, I can’t find the email you’ve sent me. Which email address or communication channel did you use?

In the meantime, we have recently published a new update for CircuitBlocks.

Please try coding your device again and let me know if it doesn’t work.

my email is

Thank you