Circuit blocks cannot connect to device on Ubuntu 22.04.2 LTS

Hi, using the web circuit block GUI on Chrome.
As soon as I tried to connect to the device (batmobile in this case) the device /dev/ttyUSB0 would disappear and there was some mention of brltty in the logs. So, like any hacker, I removed the pkg brltty. Now the device no longer disappears so I can select it but it returns with a status of “paired” not “connected”. Repeated tries fail. I don’t see anything in the logs. How do I proceed?

I’ll just note this all worked fine on my Mac Air but I don’t want to use that for dev work.

Hi Eric,

I’m with the software team in CircuitMess.

First of all, I would ask you to try out connecting to your device inside a private browser window, just to make sure that the issue isn’t due to some incorrectly cached data or 3rd party plugin.

After that you should check what kind of package is your Chrome installation. If it’s flatpak or snap, then there is a chance that there is an issue with the app’s permissions. In that case I would recommend either trying to set the correct permissions required or installing a deb package that shouldn’t have any issues with permissions.

Feel free to ask for further clarification if needed.

Kind regards,

Antonio, sorry for my tardy reply. I’ve been out of town. Will get back to you next week. Thanks for the help.

Antonio, if I run chrome in incognito mode I get an immediate error that the software only runs in desktop mode. FF doesn’t work complaining of a missing agent. What else should I try? In dmesg I see the USB device detected correctly so the error appears to be in the browser connecting to the serial device it creates. Chrome was installed via dpkg. Not snap or flatpack. Same with FF.

This is fixed. I found this error in syslog which made the problem easy to resolve
“Failed to open serial port: FILE_ERROR_ACCESS_DENIED”

To fix it:

First remove the brltty driver (something to do with braille). Here are directions that make sense but I didn’t follow them. I instead just $sudo apt remove brltty

Second follow the below directions to grant access to the id you use to start the browser to the serial device the driver created (/dev/ttyUSB0).

I also had to reboot as the directions state.