Completely unresponsive/not powered on? [SOLVED]

Me and my sons had great fun putting together the makerbuino. All went fine, first tests passed so we completed the build.
The very first time we turned it on once we completed the project it worked fine, we pressed all the input buttons as directed on screen and I worked. Then once the button inputs were registered the screen went off and we have not been able to get anything displayed since. at no point have a noticed thee backlights working even during the button presses but the backlight certainly is not coming on now so it’s acting like a completely dead unit. Any help will be most appreciated.

There was some poor soldering that I have re-done in the hope that would help. I have tried charging the battery for a few hours in case that was the issue but it still did not help.

Images of the back and front provided, the front image I actually have the unit powered on and you can see that nothing is happening.


Thank you for supporting MAKERbuino and I apologize for the problems that you’re experiencing.

Your build looks splendid so this is quite strange.

Did you try charging your MAKERbuino? What LED did light-up on the battery charger board?

This might also be fixable by performing a hard reset.

When you interrupt the loading process, the console’s memory will be blank so you have to do a hard reset like this:

  1. insert the SD card
  2. turn the console OFF
  3. hold the C button
  4. turn the console ON
  5. release the C button
  6. wait for 30 seconds
    The SD card loader menu should appear.

This was also mentioned in build guide’s chapter #4 (under the yellow section marked “IMPORTANT”)

Keep us posted and don’t worry as we’ll help you make your MAKERbuino :slight_smile:

Hi Albert, thanks for getting back to me. I have tried the hard reset to no avail. :frowning:

Hey, thanks for the update.

Did you try charging your device? What LED did light up when charging it?

Hello, it’s LED is red when I first plug it in but then goes blue once charged.

I do however have an update - after doing another hard reset I seem to more often than not get the main menu (where I can select a game but…

The screen randomly turns off and when it is visible the display is distorted
There is no backlight at all
Sound only plays through the headphone socket and not the speaker

I can only assume that something is not soldered correctly somewhere… possibly under the screen as that is the only place that I cannot check readily.

Image showing the slightly garbled display:

Hi, looking at your photos, the screen doesn’t appear to be soldered correctly. See image below. Try resoldering all these so the solder flows nicely and surrounds each pin - if you have some flux apply a little to the pins and pads and it will flow tge solder much more readily.

Thanks Rabbit80, that was it! The screen is now stable and works every time. Thanks v much and Happy new Year to all!

1 Like

Glad to help. Happy new year :slight_smile:

@Rabbit80, thank you so much for helping out here :slight_smile:

@Allan_Crumpton, congrats on making your console work.

I’ll see you both around at the forum :slight_smile: