Failure @ Step 12 – first functionality test; no screen activity

Hi, congratulations on the success of your product. I appreciate all of the work you’ve done to get it this far and the high quality of the support you provide here.

I’m having a problem at step 12 when trying to pass the first functionality test. When I power on the device nothing happens, blank screen. With my multi-meter I’ve measured voltage at a number of different places:

Battery: 3.820
ATMega328, VCC and GND (pins 7 & 8): 3.489
5110 LCD Module VCC and GND (pins 1 & 2): 000.0
5110 LCD Module GND and LED (pins 2 & 8): 1.390 (LED is not on)

Let me know if there are any other readings I can provide that will help you troubleshoot the problem.

I have a good amount of experience with soldering so I suspect that is not the problem but can’t be 100% sure of course. I don’t see any bridges. The resistor and the regulator are not swapped and are facing in the correct direction. The polarities on the electrolytic capacitors are correct. The micro-controller is inserted in the correct direction. Joints I can still see look good. I have an oscilloscope on hand if that helps, as well as a good selection of transistors, regulators and the like. I can also burn the Gamebuino bootloader onto a different ATMega328P and try that if you think it would help. I don’t think the problem is with the 5110 because I happen to have another one on hand and I can line up the holes to make connections to the second screen and still no results.

As a new user I can only put one photo in the post, so I tried to select the most relevant shot.

Dan Murphy

Hey there,

Thank you for supporting MAKERbuino and I am sorry for the problems that you’re experiencing.

Thank you for a really helpful assessment. 0V on the LCD module doesn’t seem right… can you please check on that again and try resoldering the joints?
Also, please send us some more photos as we cannot see your entire console from this. You can send them to if our forum is limiting you.

Finally, please don’t worry as I’ll help you make your MAKERbuino work :slight_smile:

Ok, the joints I needed to check were under the display, so I de-soldered the display from the PCB (not recommended under normal circumstances) and re-soldered the joints that connect the ATMega328P to the PCB. Then I re-soldered the display back on and re-executed the first functionality test; this time there was screen activity. So the problem was the joints connecting the micro-controller to the PCB. Thanks for your assistance.

Dan Murphy

Awesome! Congrats on making it work and if you need anything else, feel free to contact me here :slight_smile: