Finished MAKERbuino not starting? [SOLVED]

Hello All,
I just finished building my MAKERbuino and it worked from the first test step but once all components were soldered in and it wont start. I’ve tried putting it on the charger but it doesn’t help. When I turn it on with the charger in it has a quick blue light flash for me and then nothing. Can anyone help me?

1 Like

thank you for supporting MAKERbuino.

Please, supply us with some high-quality photos of your MAKERbuino’s front and back side without the casing.
We really cannot help you without seeing your device.


1 Like


  • can you hear the startup sound coming from the speaker when you turn the device on?
  • try doing a hard reset like this:
  1. insert the SD card
  2. turn the console OFF
  3. hold the C button
  4. turn the console ON
  5. release the C button
  6. wait for 30 seconds
    The SD card loader menu should appear.
  • You’ve got quite a lot of soldering joints that require more heat. Take a look at chapter #3 of the MAKERbuino build guide - all joints need to have a neat volcano shape, you must avoid blob-shaped soldering points.
    Resolder the joints that I’ve highlighted here:

Update us with your progress

Thank you for the response but i her no sound from speaker and I did the hard reset and i have nothing.

@Shanon_Bugg, you’re debugging too fast :slight_smile:
Take a look at the edited post above, try resoldering the joints that I’ve highlighted and any other suspicious-looking ones

Found the culprit


Well done!
Is your MAKERbuino working now?
Pics or it didn’t happen!

All good to go. Everything is working just fine

1 Like

Congratulations! Your MAKERbuino looks splendid!

I’ve just awarded you with a couple of badges! :slight_smile: