Help with Makerbuino + missing parts from the pledge [SOLVED]

Hey guys, I’ve received the makerbuino few days ago and assembled it on saturday. It’s the first time for me to solder something so I might have made some mistakes, anyway this is what happened to me:

Everything was working fine when I turned it on the first time, I set the screen contrast, press whatever I had to press and then saved the settings. Then I turned it off , put the SD card inside and turned it on again. I pressed C button and the loading of the SD seemed started, after 20 seconds the screen went back to the previous one, the one where you can press A,B or C . Then I tried to turn it on and do it again but when I turn it on now I only get a white blank screen (look at the attached picture).

After this I thought I might have made some mess while soldering the SD socket and I tried to fix it but I might have made the mistake just bigger… In the end I tried checking the SD card on the PC and noticed it is empty, no files inside the SD.

Now I think the soldering of the SD socket was fine at first, the problem was that the SD card was delivered empty. I wanna try to unsolder the SD socket , get a new one and solder again, but unfortunately my Makerbuino kit with tools came without the Solder Pump which is the thing I need to unsolder stuff is that right?

Any idea on how can I fix this?
Anyone from the Team who can help or send me the missing item from my pledge?
Thanks for the help!

Up up.
I need someone from the team to answer, I need to know if they’re going to send the missing parts from the pledge as they said. The SD card is also very poor quality, as I tried to put in and out several times to do some tries and some piece of plastic got already broken. Wrote email to the customer service but got no answer.

Hi @Tina_Gamer

I’m not affiliated with the team or Makerbuino, but I do think they’re support has been pretty poor, especially for the backers, shipping and replies.

Anyway what is the current state of you’re SD socket? have you got any images?. I doubt that the soldering pump will help with removing this component from the board. solder wick and flux will probably help but still isn’t going to be an easy task, especially as it’s you’re first time soldering.

If it is any help then here is a complete copy of my SD Card files, I took a copy of the SD Card before I even plugged it into my Makerbuino… I do know that the makerbuino uses the LOADER.HEX and SETTINGS.HEX files.
You will need to unzip the file and put the files onto you’re SD Card (not in a folder or subfolder).

Makerbuino SD Card

1 Like

Thank you very much for your answer. This is the current state of my SD card socket, what do you think? …

Btw the screen is stuck blank…I tried to upload in the empty memory card the Hex files from gamebuino and changed several SD cards but didn’t work.I now ordered a SD card socket and a solder pump (which was supposed to be included in my pledge but it is not there) and I’ll try to unsolder the SD socket… My last try before I give up , throw everything away and never back or buy anything from them. I mean if the SD card had all the files right maybe I wouldn’t have made the mess trying to “better” solder an SD socket which was fine…

Rather than unsolder, sometimes you just need to heat the solder again. Make sure you touch both the pad and the pin at the same time when you solder.

1 Like

@Tom thanks for your answer…I’m not confident touching and messing with that again. Actually the sd socket and the joints looked much better before I started heating them again trying to “fix” it. Do you guys think the joints of the SD are the problem behind the blank screen or could it be something else? As I said before when I first turned it on everything was working properly, and now the battery charges and it connects to the PC just fine , except for it can’t read the memory card.

Difficult to see with your picture. Can you make a bigger one?

I suspect that the fact that the SD card was blank in the first place was the main issue, but now that you have tried to solder the SD Card socket, this has made things worse?

I can see from the image that the SD Card terminals are all shorted out to the metal casing of the SD Card, you have too much solder on the terminals… you need some solder wick and flux which I mentioned above?. .the solder pump is only good for through holes…

also what is the solder joint on the left of the image? looks like that’s also touching another terminal?

tutorial for solder wick
Youtube cleaning pads with solder wick

1 Like

@bitfogav and @Tom Thanks for the help guys, I really appreciate! Okay so I desoldered and soldered again the SD card, the screen now is not blank anymore. It stays like this

When I press C button though nothing happens, or actually it appears on screen the phrase “loading … don’t turn off” but only stays there on the screen a second then disappears and nothing happens, it returns on previous screen with settings. If I press and hold the C button the screen stays like this

but as soon as I release it it turns back again.
I also fix that joint that Bitfogav pointed out, which was one of the battery charger joints (which works fine).
I don’t know what else I can do…
I tried my best with the SD socket , this is what I got


@AllGray and @albertgajsak a hint from you guys would be very much appreciated…

I get this exact same thing when I’ve removed my SD Card, so you must still have an issue with you’re SD Card, SD Card data lines or missing files on the SD Card…

1 Like

I put the files you sent me into the SD card, so I don’t think it’s a matter of files… I don’t think there’s much I can do at this point…have no idea. It’s a shame cause everything seems to work well but if it doesn’t load the SD card it’s just useless …waste of money :tired_face:

@Tina_Gamer, I apologize for the late reply.
You see, we’re having a hard time shipping all the Kickstarter orders and supporting the community in the same time.

Please don’t give up, I will help you fix your MAKERbuino and, in the worst case scenario, I will send you the new components needed for making your MAKERbuino work.

  1. please reinsert the SD card a couple of times and make sure the card is fully inserted in the SD socket. Reinserting a couple of times will clean the dust and oxidation from the SD socket’s contacts.
  2. blow in the SD card socket really hard (like you’d do with an NES cartridge), I’m not crazy, this works in some cases
  3. send me (or post here) the pictures of your MAKERbuino’s front plate without the screens so that I can see the soldering work on the microcontroller
  4. try using a different micro SD to SD adapter

if nothing of this works, I will send you the new PCB with components needed for assembly.

Thank you for your patience.
Don’t give up!

1 Like

@albertgajsak Thanks for answering Albert. I’ve tried several SD cards, not just changing the micro sd but also the adapter itself as well as putting all the files in another SD card(no adaptor) but it is not working. I’ve also tried to blow and to re-insert the sd card several times but these tries have no effect as well.

I notice when I insert the SD card in the socket, the screen gets blank for a fraction of second ( I don’t know if you can understand, I can’t take picture cause the time the screen stays blank is really less than a second). Does this mean anything?

I’ll post here a picture of the board without screen later today or tomorrow.


Here the pictures of the microcontroller joints

Shame cause everything is working, sound screen charger battery etcetc but the SD won’t load . As it is right now it’s totally useless

@albertgajsak Any news?

The microcontroller solders are not all perfect but it should work. The screen socket is weirdly inserted, but it should not be a problem. If it is a soldering roblem, my guess is on the SD card holder. Can you do high definition pictures?

1 Like

@Tina_Gamer, as @Tom already said, the microcontroller is having trouble communicating with the SD card. THe SD card is fine and the microcontroller is fine. What is not fine is the connection between those two.
The PCBs are all being tested before being shipped to the customers so I think a defective PCB is not an option.

The problem is most likely caused by either a weird/faulty SD card socket (although I don’t really understand what could be faulty about the SD card socket and I’ve never had a user with that problem before) or a problem/damage in the assembly.
I would suggest heating the contacts on the SD card socket and on the microcontroller again and updating us after that.

Do you have access to a multimeter or can you borrow it from someone? You can test the contacts with it and see where the problem is more easily.
Please don’t worry, in the worst case scenario, I can send you a new PCB and the other components for a minimal cost.

@albertgajsak Hi I’ve tried reheating the joints but had no luck solving the issue, I still get no sign from the SD card. I can’t check with multimeter as I don’t know anyone who has it and I’m not willing to buy one. At this point can I have more info about getting the new PCB with components? How much would that be?

@albertgajsak Nice glasses btw :grin:

1 Like