I can't turn on Spencer

Hi, it seems that my Spencer doesn’t want to cooperate (or I’m a really bad solderer).
I’m attaching photos.

I did had problems with my iron (the gray one with the toolkit). It looked like it wasn’t able to warm up enough on the tip most of the times and it was really hard to solder after the first few minutes of using. You can see on the board some scorch marks where I tried to insist.

Is someone able to tell me what should I do to fix it? All the components seems pretty stable to me. I’ll attach the photos under this post.

Thank you

Hi there @chiaramolina,
Thanks for sending all the photos and I’m sorry that you had these issues.
Let’s try to solve this together. Your soldering looks mostly fine. However, you could try resoldering the button and the capacitor pins.
Also, please try tightening the metal ring on the soldering iron by hand. It can get a bit loose when taking off the plastic cap from the tip. Turn off the iron before doing this so you don’t get burned!
After you fix the soldering pins, please continue to the next step to see if everything works https://circuitmess.com/resources/guides/en/spencer-build-guide/spencer-build-guide-3-3

Please stay in touch!
-Marija from CM

Hi Maria! Thank you very much for your answer. I’m not having much lucky in desoldering the pieces with the vacuum, so I’ll to wait for the shops to reopen and buy flux and desoldering wire.

I’ll let you know how it went.

Thank you!!

Hi there, I just had the same issue. The red led turns shortly on as soon as the power is connected but besides that nothing is happening. I also tried resoldering whatever pins didnt look perfect. Is there any other way of checking step by step where the issue lies?
Regards J-H

@J-H_L please, reach out to us via [email protected] and include photos of your work.
We’ll help ASAP.

Thank you for your patience and understanding