It does not load from the SD

Good morning, I made a clone of the makerbuino following this manual I loaded the configuration menu etc … but when I press β€œC” to load the SD games it keeps loading hours and hours and does nothing, what could be the problem, thanks

@satoo, thank you for joining the forum!

Congratulations on your build!

Please understand two things:

  1. We are not the authors of this instructable and cannot guarantee that the MAKERbuino clone you make from it will actually work optimally
  2. I’d be happy to help, but we really cannot help you without seeing your build (photos) and getting some more info.

From your vague description, this might be caused by the following problems:

  1. Gamebuino bootloader - did you burn it to your ATmega?
  2. Connection issues - please check the soldering joints on your microcontroller socket and the SD card socket
  3. SD card - check if it has the required .HEX files on it and if they are in the root folder and unzipped. You especially need to have LOADER.HEX on the card in order for this to work

Thank you for your quick response, I understand that by not being made by you, you cannot give support, according to the author, it works perfectly for you, but I also miss something so simple that I cannot see. I attached some pictures, I understand that the bootloader is gambebuinoboot_hex or only.hex, I have tested both with the same result.

Hey, you need to use a 2GB or lower SD card that is formatted as a FAT 16 card.

Using anything above 2GB and that is FAT32 formatted won’t work.

Hope this helps :slight_smile:

Btw the console looks neat!

Thank you very much, in the end it was the memory card, which although I had also tried a 2GB was formatted to fat32, thank you thank you thank you …

I’m glad it helps :slight_smile:

Please, share our project with your friend. It’s free and means a lot to our little startup :slight_smile:

por supesto :+1::+1:

1 Like