Just can't get it to work. :(

We sent our phone back to CircuitMess for repairs. Apparently, there was something wrong with the network card. We received the phone back but can’t get it to work. Signal often (not always but often) shows 99 but cannot register to network. We’ve tried a different SIM card with no change. It seems that the operating system is constantly acting strangely. I know that’s a vague term for troubleshooting purposes, but it never seems to behave the same consistently. Sometimes it says to check the antenna, and then suddenly, that’s not a problem anymore. Then the screen goes black while trying to enter the wifi password. If rebooted, the phone sometimes gets stuck in a reboot loop where it won’t start and just keeps rebooting. This can only be resolved by disconnecting the battery. The behavior is just random and it seems that every time it boots up, it has a different issue. We have checked with Ting and the SIM is indeed activated but it (the phone) has never registered to the network, in spite of numerous attempts to do so.

We just don’t know what to do from here.

That sounds more like a hardware than a software issue. You describe a short somewhere. A place where one of the components isn’t working properly.

It seems you describe the ramifications of this problem… The Ringo isn’t reading the card?
The network software is pretty glitchy. I don’t even get service in my area. I was forced to drop Ringo and get a phone for my area. The new phone doesn’t even work at home. So it’s unlikely there is something wrong with Ringo’s connection to a network.
It is probably the network.
It seems like this is either the SD card or the firmware. If you have a short, it may erase or corrupt files. This means rewriting to Ringo will not make any difference. It may be broken, and with proper guidance, circuitmess could have repaired this problem.

I still don’t understand your problem because of the overlap. It reads like a lot of problems with a short, but you don’t recognize it? We may need clarification…

Thanks for the reply. I looked over the entire phone with a magnifying glass and cannot find a short anywhere. My daughter soldered the phone (she’s 12) but I used to be a NASA certified technician and was certified to solder on the space shuttle after serving as an Electronics Technician on board submarines in the U.S. Navy. I taught her how to solder and oversaw her assembling the phone.

Went to AT&T as others in this forum have suggested. The AT&T SIM works! Can now make phone calls. But alas, cannot send texts. Yes, texting is included in the plan from AT&T. When sending a text the screen says, “sending text…” and then says, “text sent!” but the text is never received by the phone to which it was sent. We have tried 3 different recipient phones with the same results. Texts are received by the Ringo phone just fine, it is just sending that is a problem. Any suggestions for this?

Just one more thing, we’re getting used to the buggy nature of the operating system. We know when certain issues seem to pop up that the OS just needs to be rebooted again. It still occasionally gets stuck in a reboot loop, but just letting it loop for 15 minutes or so and it will eventually boot up properly. Not ideal, but it’s not like we were expecting the device to act like a new Samsung Galaxy S20 either. This was just intended to be a fun project and overall it has been.

Hi there,

The problems that you’re experiencing are not usual for the phone. Reboot loop and other stuff don’t happen on a non faulty phone. I believe that the soldering process is done well, especially if you’ve checked it thoroughly. However, only that can be a cause of these issues (as well as some broken hardware :confused: ).

Can you please take a couple of photos of the thing and send them here? Maybe there is a part that has fallen off or something. As I already said, this is not the usual behaviour.

Please stay in touch!