Makerbuino does not work any longer [SOLVED]

after building it, it works fine.
After playing a while different games nothing could be seen on the display, only the backlights were on.
I measured the interfaces and there was no traffic, i.e. no clock signals. After disconnecting and reconnecting the display pcb it worked again.
Now the same failure again. Nothing on the display. No communications. The connections between mainboard and display pcb are ok. When I want to read out with the ISP interface a failure message says no communication possible. Power supply on the board works fine.
A hard reset with the pressed C-button didn’t help.
There is no sound after switching on.

Any ideas?
Thank you

@oszi, we really cannot help you without seeing your device.
Hence, please send us some photos of your MAKERbuino’s front and back side without the casing.


here I try to send you some pictures

In reality the solder points look much better that at the pictures.
I measured between the pins of the display and controller, no shorts.
Would the controller also start with a beep when the display is not connected?


second picture

@oszi, yes, the microcontroller will start with a sound even when the display is not connected.

I really cannot see your soldering points since you’ve only posted a photo of your device’s front side :slight_smile:, please post some photos of your device’sfront and back side.

Also, please reinsert your SD card a couple of times and blow in the SD socket real hard (this will clean the dust particles) and try doing the hard reset again.

Keep me updated

third picture

first I had no beep also without the display.
I removed the SD-card to have nothing connected to the SPI interface. Than I connected my Atmel programmer at the ISP interface and checked the fuses. I changed the brown out from 2,7V to 1,8V.
Than I placed again the SD card and made a hard reset without the display. After 20s I heard a beep.
Now I placed the dispaly and it is running .

I remember that I had before sometimes problems with the brown out in other projects with the Atmel controllers. But I’m not sure if this was here the reason.
But equal it runs again and my son will be happy…
Thanks for your fast support

1 Like

Congratulations, I’m glad that the device is working again :slight_smile:

This has nothing to do with brown-out protection and inspecting the SPI interface is just overthinking the issue.
The most common issues usually include problems in connection with the SD card or/and with the LCD screen and require simple dust cleaning.

If you stumble upon any other problems, feel free to contact us via or just create a new topic on the forum!

yes it’s working, but not 100%
at the first loading of a game it was again empty screen and it needed 2 times hard reset to work again. In the following there were again several hard resets nedded. The SC card was pulled and pushed several times, I don’t think that there is a bad contact any longer. Next time I will check the VCC with my oscilloscope . Some SD cards need a little bit more current than others and I saw in the past at another project that during communication with the card the supply voltage drops down.

@oszi, I think that you’re overthinking this.
The cards are all tested before being sent to the customers and should work reliably on 3.3V Vcc that is outputted from the voltage regulator.

This sounds like a simple contact issue that happends when there is dust in the SD card slot. Just reinsert the card a couple of times and blow in the SD slot to clear the dust particles.
If the connection with the SD card is bad, the console will freeze in the process of game loading.