MAKERbuino isn't working [SOLVED]

Hi everybody,

I’m very sad…
Half an hour ago my precious, beloved MAKERbuino has stopped working :frowning:
The LEDs aren’t even turning on! There’s no sound, there’s just the green screen…
Even the charger circuit’s little notch came off, when I tried to turn it on :sob: So I don’t know what to do…
Maybe then I need to buy a new one? AND the C button trick isn’t working at all.
Thanks for the answer!


Check first if no wire could have be broken. Keep the Makerbuino pluged some hours and try again first. If after you cant turn it on, send photo of your console, maybe something could be seen on board…maybe… else pros of electronical of this forum will help you to chck what happen on your console, i think. You can always buy another anyway, but for good reasons, not because of an easy poblem (i hope that it’s case…)

Thank you @Jean-Charles_Lebeau I already fixed it. The problem was that the charging circuit was a little bit dismounted
and when I cahrged it, it just got a little bit of power. So I fixed the charger and then started charging my device and then BOOM! the starter screen appeared. So I was happy with it. :slight_smile:
So keep up the good work!



Good to hear that your MAKERbuino is working again! :slight_smile:
I’ll mark the topic als solved :slight_smile:

1 Like