MAKERbuino Not Working

So, we funded the Kickstarter campaign and got our kit in the mail. We were very excited and immediately got to work. During the initial test to see if everything is working so far, it was not working. So we continued following the guide to see if it would work after completion. Now after everything is done, it sort of works. The back light for the screen turns on, and we can change the intensity of the light, but nothing ever shows up on the screen. This all leads me to believe that our kit is put together just fine, but a faulty component is to blame. Can anyone offer any assistance?

One other thing while I am here posting. We ordered the Inventor’s Kit and received all the extra wires and stuff, but no breadboard. Is there any way we can get this shipped to us?

Thanks in advance for all the help and the great kit!

Hi
I ran into the same problem as you (device not working at step13 in the build guide), and also kept building in hopes that it was just an error in the guide that the device should be functional at that point.
Backlight will work if you finish the build yes… this is because it has nothing to do with the microcontroller or screen itself, but is simply a set of LED lights in circuit with the potentiometer that lets you adjust their brightness.
I, like you, was convinced I had assembled and soldered everything corrently, and that a faulty component HAD to be the reason my makerbuino wasn’t working.
Out of frustration I desoldered and removed a bunch of components again to double check that they were correctly placed and soldered, and waddayaknow! Turns out I had bent one of the pins of the microcontroller socket, so it wasn’t soldered properly.
I desoldered and removed the socket (pain in the ass, but doable), fixed the pin, resoldered the socket et voila! device now works!
Im not saying you necessarily have the same problem… Just double and triple check everything…

Regarding the breadboard you should write the creators directly and make them aware… Im sure they are busy, but also sure they will send you a board once they get around to your message.

1 Like

Hello Tommy,
I have the same problem (screen lit but nothing showing on it)
I checked all components are in the right place, and soldering looks fine according to some experts of this community. But problem is not solved.
How did you desolder? I didn’t receive anything to desolder! Can you tell me how I can do it without running around and finding a tool to do so?
Thank you :slight_smile:

A solder pump will help with some connections, but you’ll need flux to remove solder from others (like the sd card). All available on Amazon or similar. There are others posts here about the same thing.

Tommy,

I will look at this again. Thanks for your response and help.

How can I contact the makers directly for my breadboard? I tried sending an email but no response. As you said, they may be busy.

As mentioned above a solder pump is the way to go… I was actually able to visually determine that one of the socket pins was bent (remove the controller chip and look down from above and in from all sides), I would look for that before desoldering stuff… You are absolutely certain you soldered the socket in the right orientation right? (small indent on socket should match the one drawn on the board)

you can try sending a PM to albert here on the forums, and maybe try the kickstarter page as well… Probably they just haven’t gotten around to your mail yet


All looks fine with the micro controller…
Ah!! This is frustrating! I’ve been waiting for this Buino since may!
I tried to message @albertgajsak last week but still no reply!
Any other suggestion? I’m really getting tired of this, man :confused:

I want to add that when I turn the screen and play with the buttons I can actually hear sounds! But nothing is displayed on the screen! Just sounds of buttons!

these sounds… are you talking just the “clicks” of the buttons themselves (which are loud), or synth sounds coming from the speaker?
If its the last, then the screen is (somehow) your problem, as it is very unlikely the microcontroller would function as far as to play back any sound at all if it wasnt soldered and connected properly.
A faulty screen I think is fairly plausible… Though I assume they did some QA on these, they are repurposed screens from old phones (yes, some poor chinese guy desoldered yours from a phone somewhere)
Double, triple check the screen…

Frustrating with lack of communication from the creators… I hate that and its unfortunately an all too common thing for kickstarters.

Thanks man for replying and for your help!
Yeah I heard sounds coming from the speakers but now i can’t hear those anymore!
I guess faulty screen! Cause I’ve tried everything!
Maybe I should ask them to send me another screen and a micro controller just in case!
Would a micro controller be short-circuited through soldering? Is it possible that I did something and short circuited it?

And I totally agree with you Tommy!! Communication is key! So yeah super fustrating!
Thanks for your help man :slight_smile:

Im no expert, but I would think the microcontroller should be either completely dead or working fine… not in-between. So sound from the speaker (coming from a game or menu fully loaded and running) indicates to me that it is fine, and that the screen is the problem.
Did you maybe just turn down the volume by accident (the other turn knob, not the one that adjusts brightness)?

Yeah I tried playing with the sound, but it does not work anymore! I don’t know what is wrong!
I will ask for another screen i guess! the problem is that they are not answering me back, which is frustrating!
but thank you Tommy!! :slight_smile: highly appreciate it man!

Have you checked what you have not hard switch off the sound with the left switch ?
Have you check that HP connexion hasn’t been damaged (solders, wires, …)

Hello Jean Charles. Yes I just checked them mate! The wires seem okay and the switch is on! Still no sounds. And no brightness! The screen is only lighting up that’s it!
Still no answer from the creators! …

Hi I need help! there isnt clear enough instructions and my transistors were soldered wrongly and when I tried to remove it, one of the transistor legs came out! I damaged the whole transistor and thats just 2 of the more deadly problems i have encountered before i could get the screen working. The PCB is ruined T.T need help and advice on how to proceed!!

To remove a solder, it’s better to have a pump (it’s not expensive). You prepare it, you warm the solder, and when it’s liquid, you approach the pump and use it to remove the liquid metal. If the leg is always ‘pasted’ on the boad, you wait a little (you can make another leg) and retry but this time, you can move the leg when you use the pump too and you continue to other legs to remove. I’m not english (i’m french) so i hope what my explanation is enough corect to help you. Good luck (and if you have only the transistor to buy, it’s not expensive)

Hi @sak41! I have the same situation as you…screen backlight on but nothing else displayed and no sound (edit: I’ve just read on and seen that you DID have sound at some point so perhaps different problem to me after all…). I suspect the fault lies within the MCU not being programmed with the bootloader and here’s why:

I’ve thouroughly checked the solder joins and that the similar looking voltage regulator and transistor are indeed in the correct positions on the PCB. LiPo is delivering about 3.9V and the voltage regulator seems to be doing the job as checking pins on the ATmega socket (as per @bitfogav post…sorry don’t know how to link to but please see below) to show voltages around 3.28-3.30V

Next, I checked to see if something was wrong with screen. I soldered on pins to get a reliable connection as my dupont wires didn’t like the round connectors at the bottom of the Nokia screen. I followed Julian Ilett’s youtube video (https://www.youtube.com/watch?v=RAlZ1DHw03g) on how to drive the Nokia LCD with a simple sketch and it worked. So LCD display ok.

So why no display, it has power and all components are where they should be and soldering looks fine. I suspected the microcontroller. I’ve inspected the joints and out of desperation even reflowed them just to be sure. The chip was handled carefully and no problem inserting (I have worked with these on other projects). Next, I followed @Gemberkoekje post “Getting the ATmega and the LCD screen to work with Arduino Uno”. Nothing displayed…only the backlights remain functioning.

I suspect the ATmega328 chip included with my kit was not programmed with the bootloader. I have an arduino board that I can use as an Arudino as ISP for programming but don’t know where to go from there.

@albertgajsak, I hope what I have done makes sense and that you would agree that an unprogrammed MCU is a likely problem. Would you be kind enough to send a replacement or please provide instructions on how to burn bootloader (or whatever is required) to the ATmega328.

2 Likes

I have exactly the same issue, has anyone find a solution?

You should use the FTDI board. Plug it to the 6 pins header, pay attention to the orientation. Check the ground pin for that. Then connect a USB cable, and use the Arduino IDE to upload the main program.

I followed @kmatch’s instructions for burning bootloader to MCU and confirmed by hooking up mcu to lcd via arduino (as described by @Gemberkoekje). I saw Gamebuino screen followed by screen saying to insert SD and restart.

Reinserted MCU into MAKERbuino and had audio for a while (the makerbuino chime) but lost it. I lost audio after pressing a few buttons (A then B then C) in fustration after still no display (aside from the 4 LEDs that can be controlled by the left potentiometer). No sound via headphone or speaker (and connections still look fine).

LiPo battery and charging circuit working.

Any ideas?