Makerbuino SD Card Makes the Unit Reset [SOLVED]

@Elwing, the issue was caused by an incompatible 3rd party voltage regulator that the user decided to use.

Please, create a new forum topic and include some photos of your MAKERbuino’s front and back side without the protective casing.
Alternatively, you can contact us directly here:

Thank you for supporting MAKERbuino and don’t worry, we’ll help you make your MAKERbuino work

Hello. I live in a third world country and cannot afford $80 for the makerbuino kit so I made my own gamebuino based on the schematics that was presented on the makerbuino website. I followed most of them except for the icsp, breakout, tp4056, speakers, and that master-slave connections because I deemed them uncessesary. I bought most of the essential components like the lcd, mcu, ft232, sd card slot, sd card, and other passive components. But instead of mcp1702, because it wasn’t available locally, I used an lm317 ic set to output 3.3v. I also uploaded the gamebuino program into the mcu. It works. My problem now is that when it is trying to access the sd card, it just resets. Even without the sd card, it resets when I press C. I uploaded the Loader from the utilities of the gamebuino classic library and it just flashes the title screen without stopping. So please, I need anyone’s help on this. I would appreciate it. Sorry for my bad english.

Here, the video in case you want to see.

Hey, thanks for joining the forum.

I’m sorry that you couldn’t afford a MAKERbuino kit for yourself. You could’ve reached out and I might have given you a discount :slight_smile:
Anyways, congratulations on a cool build!

This looks like your microcontroller is resetting due to power supply issues (brownout).

The power supply that you’re using looks like a micro USB cable which is 5V.

You need a 3.3V output, but the LM317 needs 3V of bedroom to operate properly.

That means that you either need a microcontroller with a lower dropout voltage or you need to deliver a minimum of 3.3V+3V=6.3V in order for it to work properly.

Hope this helps and good luck with your build!

Wow! I didn’t expect anyone to reply so soon, but from the creator himself, I am truly grateful. :grinning:

I already copied your schematics and I don’t want to abuse your kindness by taking you up on your offer of giving me a discount knowing that people who bought this kit paid full price or more. I just want this thing to work like it should. But thanks, anyways.:blush:

So I did what you advised, but unfortunately, it still gave me the same results. I’ve read the datasheets for the lm317t, and it said that the voltage difference between input and output should be 5v. So I followed through. The outcome was no different.:expressionless:

There aren’t so many components available locally, so I have to settle with what I can obtain through desoldering scraps from old radios and electronics.

Perhaps the only way I can play games on this is to directly upload the code to the microcontroller. Guess I’ll try that.

Thanks for replying!


Thanks for your reply.

  1. Please measure the voltage on the microcontroller. Is it 3.3V?
  2. Is the SD card that you’re using >2GB and FAT16 formatted? It needs to be like that or else it won’t work

Yes. I’ve measured the voltages and the sd card is 2gb (FAT).


The things that I’d check if I were you:

  1. try doing it with another SD card
  2. Check if the files on the SD card are unzipped and in the root folder
  3. Check if there is LOADER.HEX on the SD card
  4. check the connections between the microcontroller and the SD card with a multimeter

Hope this helps

Also, check once again if you’ve burned the bootloader properly

I’ve encountered this problem before (it resets when I press c) when I built my own gamebuino (before the actual one arrived) and I discovered it was because the bootloader was not flashed.
Maybe you could check if the bootloader was flashed correctly?
I guess you havent flashed the bootloader because you do not have the ICSP header…

1 Like

@YEA, congrats on building your own MAKERbuino as well and thanks for supporting the project :slight_smile:

I agree, that might be the case here. I first though it was connected to the power supply isues, but not having a bootloader will have this effect here

It’s a new microcontroller that I bought. Maybe that’s all that’s missing. I’ll try to burn the bootloader with another arduino by following their instructions online. I highly appreciate the reponses.:blush:

1 Like

Also, MAKERbuino uses a different firmware from standard Arduino, make sure you flash the correct one!

May I ask if you can tell me what is the firmware?
there are instructions to flashing in the middle, but scroll down to bottom of page to download

1 Like

Hello, Albert
Can you share more information of that investigation? I am using buck-boost converter (with no filter) instead of LDO, which gives 3.3v ± 50mV ripple at 5kHz, and expereincing the same issue with unit rebooting. So I am wondering, what are the requirements for the voltage stability and level, in case that was the issue you discovered.
Funny thing is - arduino ide has a builtin SD example sketch, which works fine, showing SD capacity (1GB), vendor code, etc.
Buckboost IC is TPS63031, rated max 800mA.
Fusebits have BOD disabled.
Thank you.

EDIT: adding HUGE low pass filter 470uH+1500uF gave no effect. This eradicated standby ripple completely, but I was still getting -50mV drop at the moment controller initializes card.
Next thing, I swaped buck-boost IC with 1117 LDO - this gave -20mV drop at initialization, but the thing still reboots. What the hell


Thank you for joining the forum.

umm… I am not sure which information you’re talking about, but I’d recommend sharing a schematic and some photos of your design and maybe I’ll be able to help you from there

Thank you for replying so quickly.
The info I am interested in - what was the evidence that made you conclude LM317 (LDO Budoy_ness used) was the root of the problem, and why it was incompatible in general. It is rated 1.25A, so why not?

I don’t have a schematic, here is my pcb. I know, it is not much of a help)

EDIT: Nailed it, it was a bootloader issue! Reflashing it did the trick.
By the way, is gamebuino_boot.hex, built 30.12.2016, the latest version? I’ve got mine here

Great, I’m glad you’ve managed to fix that.

The problem for LM317 is that it requires 3V of headroom (VI – VO) to operate in regulation. This means that if you want an output of 3V, you need an input of 6.3V and the battery used on MAKERbuino only has 3.7V of nominal voltage.

Btw nice PCB. Woah, your vias are huge, you can try making them smaller, you know :slight_smile:

Those huge vias are for buttons’ leads, but leads are shortened in order to not come out this side to puncture the battery. Other vias are 0.3mm.

As for LM317 - agree, not suitable for lithium battery, but dropout voltage is not constant 3v. I would say, you could barely make it to 3.3 output on 5v input

Back to the bootloader. Can you please pinpoint the link to the latest version?

I’have also found this bootloader, worked for me. It is 2K size, so fusebits must be set L:FF H:D8. Anyone else encountering bootloader stuck in “flashing loader” state - check your SD is <2G size, has no errors, formatted FAT(16) and LOADER.HEX is present on it.

Always check your fusebits and remember that arduino’s stock bootloader is incompatible with gamebuino.

Here is the latest bootloader:

Thanks for the rest of the tips