Makerphone keeps calling after I hang up

I have noticed that when I call a number that doesn’t answer, the phone frequently keeps trying to complete the call, continuing to ring the called phone long after I press “Hang up”, and even after I’ve gone back to other menus. I would think “Hang up” ought to immediately terminate a call.

Note: it doesn’t do this all the time, and when it does, a reboot seems to bring it back to properly hanging up, at least for a while. This is with a 4G cellular module.

Hey Frank,

That is very odd, as nobody has encountered that problem yet.
Can you please record a short video of that occasion so that we can check out what is really going on?

Thanks in advance,

Robert, here are 2 videos. The first shows the problem occurring. Then I powered down and powered back up and repeated the same test; in the second video, the call is terminated immediately when I press “Hang up”.

Phone exhibiting problem - not hanging up

After reboot, phone hanging up normally

Okay, but when does the problem re-appear?
Does it happen immediately on the second call after restarting the phone or is it random?

I just tried it 3 times in a row after a reboot. It worked perfectly each time. After the phone’s been on for many hours, then it seems to eventually occur. In other words, it’s random (or seemingly so). I’ve seen this more than a half dozen times during testing over the past few days, but I can’t create a scenario that reproduces it (I know, those are the worst!)

I’ll keep looking for something that reproduces the problem.

Yes, we know about that one!

Having a problem and then not being able to recreate it when you want it - the worst.
Keep on a lookout and send us a message if you notice some patterns.

Also, we are pushing a new firmware update as we speak so that might fix the problem as well.


Updated to firmware 1.0.1, but I still saw this situation occur once. Still hoping to find out what sequence of events triggers it.

It seems that you have some troubles with the SIM module, because you have several problems from the same source.

Tell me when you find out or at least get an assumption.

You may be on to something there, Robert! This SIM7600SA-H was a replacement I bought from Erik Rudec on 18 October because my original 2G module could not receive a consistent signal from Ting/T-Mobile in my area. When I started using the 4G module, the signal situation improved but I did notice 3 things different:
. The boot up took much longer (perhaps 30 seconds vs. 10 seconds for the 2G.
. When I ask for “Force time sync” under “Date & time”, the time gets set 4 hours later than the current time (with 2G module, it got set to current time when I could get a signal).
. Twice now (in very many power ups), I’ve gotten “No module” on the home screen (restarted again and worked ok).

Erik said he sent me the SA module because it covers the most frequencies; however it is missing the 700MHz Band 12 that Ting/T-Mobile says provides the very best signal in my area. Only the A module covers that frequency. Still, it works well enough to satisfy me, but now you cast some doubt on its operation based on these other two issues.

I’ll try again today to find a way to reproduce both of them, but it doesn’t seem very predictable. I know the 4-hours in the future time setting is reproducible (perhaps UTC isn’t getting converted to a local time by Ting/T-Mobile because of the SA module?)

After reproducing my other problem this morning (see topic " Strange notification on home screen"), I tried calling my cell phone from the Makerphone (without cycling power). The signal was good. On the first try, it said “Calling” for nearly a minute but I heard no ring either from the Makerphone speaker or the cell phone. I pressed “Hang up”, then dialed it again. This time it rang through; I didn’t answer, but pressed “Hang up”. As before, the cell phone continued to ring. I then went all the way back to the “Power off” option and turned it off. Curiously, the cell phone STILL continued to ring for about 10 or 15 seconds AFTER power off! I know the power turned off immediately because the little dim LED on the back of the main board went off. Strange goings on.

That then certainly shows that the hardware is not the problem. If the phone is turned off and it still gives out signal calls, that means that provider didn’t get the info that it should stop the call on time. That would definitely suggest that the signal in your area is very weak (as it was the case with the 2G module).

In the area of good signal that information should arrive instantly and the call will be dropped at the same time.

Did you have these problems in some other areas, perhaps here the network is a bit better and where the signal bar is full?

I haven’t rebooted the phone since that last try, so I tried again and the problem remains. I checked the signal strength before and after the call and it was 18, which is 2 bars on the triangle. Once and a while it goes down to 7 (1 bar), but the problem is consistent regardless until I reboot. I don’t think your explanation applies here.

Also, when I got that empty notification yesterday at the supermarket, I had been checking signal level around the market and it was rather consistently 3 bars, so I don’t think weak signal explains that problem either. When I only had the 2G module, I drove about 2 miles around and the signal triangle was either empty (no bars) or had an X next to it (no signal at all). So there is a difference in reception with the 4G module, it’s just that at my house, I need to be near a window to get it up to 1 or 2 bars, which is consistent with the Ting coverage map for 1900MHz 4G at that location.

So I think the phone’s reached its terminal state without doing a reboot. I took it to Home Depot with me where the signal was very strong. I tried the outgoing call and it wouldn’t hang up (the reported problem). Later, after the cell phone timed out, I tried placing an incoming call; instead of either the call going through, or the empty notification coming up, what happened is that the home screen lit up but with the colon (and other things on the screen that normally blink) blinking very slowly, perhaps 2 seconds per blink. No ring, no screen showing incoming call. As soon as I hung up the calling cell phone, the blinking resumed at its normal rate. So this is sort of the terminal state in my mind, and I’m now going to try a power cycle…

After a power cycle, the incoming call was once again ringing through, and the outgoing call terminated the moment I pressed “Hang up”. Both with only 2 bars signal level. In other words, the power cycle returned operation to normal.

So the mystical magical factor that is causing both of these problems is apparently “time”; that is, as time elapses since the last power cycle, something deteriorates. Some memory is getting corrupted, or something of that sort, as a result of the passage of time. Starts off good, later goes bad. I’m out of experiments. Any suggestions?

Hey @frankprindle and @glennjammin,

We think we have found a simple solution for your problems.

One of our customers also had a similar problem and it disappeared when he changed the microSD card. So I would like to ask you to acquire a new micro SD card (or if you have another one at home, use it), format it to FAT32 and copy everything from this repo to it .

Ringo SD card contains some data and settings files that handle these kinds of things, so if an SD card is corrupted, some of the basic functions will not working properly.

If you fix it by changing an SD card, we will send you a new one for free.

Thanks in advance and stay in touch,

Well, you had me pretty excited though it sounded a little far-fetched. I used a SanDisk 32GB SD card and copied just those files to it (from the link you gave). Powered up and tried incoming and outgoing calls. Incoming call immediately displayed the blank notification with various misplaced text on the home screen, while outgoing call worked (and hung up) just fine. Waited approximately an hour and a half and tried same. This time incoming call produced the slowly blinking colon and no ring (what I had previously called the terminal state), while outgoing call went through but refused to hang up when the “Hang up” button was pressed. So not only did replacing the SD card not help, but the situation seems to be getting worse; when I first received the 4G card, none of this was going on and it seemed to work fine for a few days at least; now it’s all poop.

Later today I’m going to go back to the 2G card and see if it also experiences any of this. I need to go outside (it’s raining now) and about stand on my head to get a 2G signal, but I’ll try to see if I can reproduce any of this with the 2G card.

And just to check again… this couldn’t be the result of the South American 4G module being somehow incompatible with the T-Mobile/Ting system here in the USA???

1 Like

All right folks, finally an experiment that successfully isolates the problem. I powered the phone down, opened it up, removed the 4G module, installed the 2G module, put it all back together and fired it up. Went out on my back patio and wandered around until I got a signal level of 2 to 4 and repeated the incoming and outgoing call tests. With the 2G module, the incoming call registered the correct number in the notification, while the outgoing call hung up immediately when I pressed the “Hang up” button. Left it powered on for 1.5 hours, went back outside, found a signal, and repeated the tests with the same results (i.e.: perfect, even though the signal strength was minimal). Lastly, with the 2G module still in place, I tried the “Force time sync” and it worked perfectly, setting the clock to the local time (EDT).

Then, I again disassembled the case, removed the 2G module, re-inserted the 4G module, put it all back together, and repeated the tests yet again. Immediately after power up an incoming call showed as a blank number with the text “OK” below it and more text “RING” below that. The call log showed “OKRING+CLCC: 1,4,4,0,”, whatever that might mean. The outgoing call test worked this time. I waited about 45 minutes and tried the outgoing call again. The first time I tried, there was no ringing on either the Makerphone or the called phone; I hung up. The second time I tried, I could hear ringing at the Makerphone and the called phone rang, but did not stop ringing until long after I pressed “Hang up”. In other words, the problems listed above came back. Furthermore, I tried the “Force time sync” and it came back 4 hours in the future, just as before.

I believe today’s experiments show that the problem follows the module, not the phone nor its firmware nor the SD card, since the only thing I changed was the module. Somehow this South American version of the module is NOT compatible or is going flakey and a power cycle restores some functionality briefly (though not the ability to properly sync time).

Could you swap this suspect SIM7600SA-H for a known working SIM7600A-H? Then you could test the suspect module at your end to see what its failure mode is, and I might have a 4G module that actually works.

Thanks for putting up with this long drawn out problem isolation - I should have thought trying this sooner.

Hey Frank,

The problem is that you cannot just switch between the 2G and 4G like that.
Each 2G and 4G module have their own DIFFERENT main boards, which you have been informed about when we sent out the second module to you.

2G and 4G modules do not work on the same board!

That is why you’re experiencing issues, I had no idea that you installed 4G module on the 2G module board. The main difference between the boards is that 4G board has some additional components right below the SIM module, which you will easily see if you compare those two.

You would have to install the components to the 4G board along with the 4G module if you want them to work properly.


I’m afraid you’ve missed the point, Robert. The 4G module came (via DHL) mounted on a main board that I can only assume is a 4G main board because that is what Erik Rudec said he was sending. I did not try the 4G module on the 2G board, but I did try the 2G module (on Thursday) on the 4G board and it worked fine. But the 4G module on the very board it arrived mounted on (which I can only assume is a 4G main board) is the one that I’ve been reporting this problem about since the beginning of this topic on October 29th. As I said, the 4G module (on its 4G board) seemed to work at first try but I quickly noticed the strange hangup behavior which is the whole purpose of this topic.

So please don’t jump to conclusions that are unfounded. My conclusions are based on a proper scientific approach to troubleshooting (which I’ve been doing from both a hardware and software perspective for over 50 years).

And all this is at odds with Albert’s statement in Kickstarter Update #35 where he said:
"…every MAKERphone will come with an interchangeable socket that will allow you to easily swap your 2G module for a 4G one (it uses a standardized mini PCIe socket). We will sell 4G upgrade modules separately and will make them available in our shop later this year."

1 Like


And all this is at odds with Albert’s statement in Kickstarter Update #35 where he said:
"…every MAKERphone will come with an interchangeable socket that will allow you to easily swap your 2G module for a 4G one (it uses a standardized mini PCIe socket). We will sell 4G upgrade modules separately and will make them available in our shop later this year."

I’m sorry, but we didn’t manage to make that happen. I think I’ve addressed that in one of the updates, but I am sorry if it got lost in all the other info that I’ve been writing over there.

2G module in a 4G main board will not work as expected. Same goes for the 4G module in the 2G main board.

I’ve been following your thread here and I must say I’m a bit overwhelmed with all the info that you’ve posted here.

Please, can you please tell me again what exact problem you’re having with your phone?
Keep it short and sweet, please :slight_smile:

Thank you for your support and I’ll see you around at the forum :slight_smile:

Ok, short and sweet (all about SA version of 4G module in a 4G board, and all with a 3-bar signal strength):

  1. After power on then wait hour or so, “Hang up” will not terminate outgoing call (see videos in 3rd message above), or outgoing call will never initiate (says Calling xxx-xxx-xxxx but never hear ring on either end).
  2. After power on then wait hour or so, incoming call will either not display calling number or will cause colon on home screen to blink much more slowly but not show incoming call at all.
  3. 1 and 2 do not occur immediately after power on.
  4. Even immediately after power on, attempting to “Force time sync” results in a time 4 hours into the future (the 2G module on 2G board correctly gave local time).