Nibble trouble with graphics


Just soldered my Nibble successfully 2 days ago and I love how it looks. Everything worked fine (after resoldering the battery, casing was wobbly due to the diagonal wire). Then I installed CircuitBlocks and started coding - but I can’t get no graphics to show up on the screen no matter what. Instead the screen blinks black and lightgrey. None of the screen functions give any visible output. Sound works fine, however, and using the “button pressed” event works. Tried reinstalling CodeBlocks, nothing changed. Restore firmware button works correctly. I’m running win10 on a laptop.


Hello, Edgar!

This could be a couple of issues. The first one is a missing “draw sprite to display” block. All the screen functions draw to a temporary buffer in the memory of the Nibble, to actually get anything on the screen you need the “draw sprite” block which transfers the contents of that buffer to the screen.

The second issue, and this one seems more likely considering your description of the display blinking black and grey, could be that you’re using the “print” functions before setting the font size, type, and/or color. Before any text can be drawn, its font, color and size need to be set.

Let us know if that helps resolve your issues.


D’oh. :crazy_face: the draw sprite block it was. Thanks!

Everything works fine now. Time to do that raycasting maze game now :grin:

1 Like