No 4G connection in USA

I completed my Ringo with 4G SIM model without issue, upgraded the firmware via wi-fi, inserted the Ting SIM, and am unable to make a connection. Thinking that I forgot to activate the SIM card, I went to the Ting website, but could not activate the card. Upon contacting Ting customer service, I provided them with my SIM7600A (no, it has no -H) IMEI number, and just received an e-mail back stating I needed to upgrade to a 4G LTE capable device, as they would not support 2G/3G beyond the end of the year. I thought the SIM7600A was 4G LTE? I then went to the US FCC site, and input the FCC ID from the SIM7600A module, and was surprised to find it was not registered by the FCC (using FCC ID UDV-201709 as printed on the SIM module.)

I normally use AT&T as my carrier, and put my AT&T SIM in the Ringo - still no connection. It just sits forever saying “loading” on the main screen.

In looking over the forum messages, I don’t see much in the way of solid evidence the SIM7600A SIM module works consistently in the USA. I’m near a fairly large city (Los Angeles) and have had no success trying various locations with good signal strength.

Anyone have any thoughts?


Mark, welcome! Please see the following post for more information:

Many of us have had issues with Ting. We take a deep dive into networks and SIM modules in the US. I think it will address all of your questions.


Thanks for the fascinating read and, more importantly, the amount of effort you have put in to understand the issues and communicate those to the rest of us. I’m an RF guy who designs antennas (nothing as small as what’s in use here, but maybe a new project for me as well - since this appears to have a bearing on the overall issue?), so to read the software/firmware/network side of things has been an education.

When I tried my AT&T SIM card (from my working and active phone) I may have thought that the signal strength at my location was sufficient, but now I see that the Ringo struggles to see anything. I’m still testing, but the SIM module/antenna combination - probably more due to antenna efficiency - appears to be significantly less sensitive than my old Nokia Windows phone. I’m going to drive up near a cell I have identified as carrying AT&T and see if I can get a good signal and try to register my AT&T card and make a call to at least establish a working combination.

Again, thanks for the insight - this has been educational if nothing else. I’m convinced the folks at Circuitmess picked a module that had a reasonable expectation of working, but the fractured US cell-phone infrastructure appears to be a real challenge if you are not a “tier 1” supplier.


Hey Mark,

Sorry for the issues you’re having! Another thing that might work - just try another service provider. SIM7600 only supports some bands and providers only provide certain bands in certain areas. That’s why some of the folks have great experience with one provider, while other just don’t. If you find the right provider for your area, everything should work fine.

The situation in the US is much much worse than any other country in the world, which is to be expected due to its size, but still, it causes much more trouble than it should.

Also, did you try just making a call? Even though it says “Loading…” doesn’t necessarily mean that it doesn’t work. Try to call that number or from that number and see what happens.