Ting not providing voice/text over 4G

Hello! I have a 4G Ringo and I tried to activate my Ting card today, and they said that their network (T-Mobile) will only support 4G on the phone (data) but not 2G or 3G (voice and text). Are they wrong? I don’t see any threads about this, but I’m pretty sure the 4G phone works on the Ting network for voice/text. I’m based in the US. Thank you.

1 Like

Voice can also be sent/received over LTE via VoLTE. The SIM 7600 module family says it supports VoLTE. Note that the 4G module should drop down to 2G GSM for voice if the carrier doesn’t support VoLTE, and so far 2G GSM voice still works (marginally) on Ting/T-Mobile. I can’t imagine why Ting told you they don’t support 2G GSM (unless they’re well aware that it sucks). They also support 2G CDMA on a different plan, but the SIM7600 can’t do that.

Since CircuitMess has supposedly tested the 4G MakerPhone with Verizon, 4G VoLTE must work because Verizon doesn’t support GSM. Whether Ting supports 4G VoLTE remains to be determined. You could certainly ask them.

Have you tried to make a call on Ting? If it doesn’t work indoors, have you tried it outside?

I’m waiting for my 4G to get to CircuitMess for replacement and then back to me; then maybe I can do some more experiments.

1 Like

Ouch…this is not encouraging at all. So, I just got my Ringo today and put it together in a snap. Mine is also the SIM7600A-H model and I’m in the US. Tried Ting SIM and activated it. I have signal hovering around 20.

Registration is fine, receive SMS just fine. I send an SMS from Ringo and my other phone (t-Mobile) receives it, but Ringo never shows confirmation and remains on “sending message…” forever…until a forced reboot OR I send an SMS to Ringo, which is received and interrupts the “sending message…,” shows “Text sent,” and returns to the Inbox. (It loses the string it was sending and shows a blank outgoing message, but it receives the incoming SMS string just fine)

Calls simply do not work at all in either direction. Ringo sits on Calling screen until failure or hang up without ever sending the call. Inbound calls go to VM. When I spoke to Ting, they claimed that VoLTE should work by default (that is what they are using) and even the lower 2G/3G fallback should still be available in my area.

I worry this may be a firmware bug with the 4G version on T-Mobile/Ting. I suspect that the SMS sending bug is, at the very least…if it were simply signal strength, I wouldn’t be able to “escape” from the send routine by receiving a new message and I doubt the sent text would be making it to my other phone so reliably. Maybe the firmware is expecting a certain response from the modem that may be differing on T-Mobile’s 4G, resulting in it never processing the network acknowledgement that the SMS sent? If it would just process the acknowledgement and return to the inbox, SMS would be working 100%.

I couldn’t begin to diagnose the calling issue, as I get nowhere with it any which way. Since the only issue SMS seems to have is with send confirmation, at least some part of the cellular connectivity is functioning properly.

Has anyone been able to get Ting working properly on this? Seems wasteful to have partnered with Ting to put SIMs in the kit if it isn’t going to work well with them.

Hey there,

Thanks for this deep dive and an explanation of what’s going on.

The whole deal with Ting was made back in the day when they supported the 2G network and everything should work fine on 4G as well. In the meantime, however, they started working with T-Mobile and obviously changed something on their network. 4G versions of the phone were still functioning properly so it’s really weird to hear that this is not working now for you. It is possible that something has changed over the last few months since we had reports of people using Ting/T-Mobile and everything had worked perfectly.

What I have to ask you is, if it is no too much trouble, to try some different service provider SIM card just to see if the phone is functioning properly. Once we establish that, we’ll focus on finding out what is actually going on here and try to fix it.

I hope you keep in touch and help us fix this problem! :smiley:

Thanks for the good will and cheers,
Robert

Well, I did try my T-Mobile SIM with the same results. I don’t have any other carrier SIMs handy.

I am going to venture out this weekend and confirm for sure if transient network conditions are having any effect. I certainly can’t expect the same quality of signal on Ringo as a modern smartphone, given the differences in build/antenna size/chipset/etc…so maybe my coverage at home is worse than it appears from my Note9. :man_shrugging: I’ll report back with more findings soon.

Another tidbit that may prove useful: When I return from a game/app to the main launcher, I have no cellular registration. I have to toggle airplane mode on/off to get it to register again.

Is this the case with other carriers/radios? If others re-register properly when returning to the main OS, this may shed some light. I’m beginning to wonder if this is partly a timing issue with T-Mobile’s network. Here’s my thinking:

  • SMS send hangs waiting for confirmation from the network…I did have ONE attempt last night randomly proceed to “Text sent” (in about half a second from pressing A) and back to the inbox, out of over 300 attempts so far. This might indicate that the network is replying back SOOOOO fast that the code isn’t yet ready to receive it and misses it…resulting in an endless loop waiting for something that already happened
  • Could explain call handshakes not completing, as well…responses from the network are too fast for the code to receive/react properly once it sends the initial call request to the VoLTE network…so it hangs waiting for something that already happened (call request acknowledged and request to setup RTP audio channels)
  • IF the main OS is re-initializing/re-registering the radio for other providers when you return to it from a game/app, a timing issue could explain why a manual (read: slower) toggle is needed to get re-registered for this one

Now, the real question: How do we test for this possibility? Perhaps the SIM Module Debug? Haven’t the foggiest how this applet works, beyond showing detected networks, tho. Is there a way with the main loader to push this SIM debugging information to the Serial Monitor or a log file so we can see what is happening as these things are failing?

@robertCM, I am a [deeply] seasoned software dev, if you would like me to test out-of-band source code changes or experimental firmware, I’m all for it. This could be quite helpful since you have no way to readily test this particular radio/provider/location combination from where you are.

I have been trying to glean useful information from the serial monitor, but this hasn’t shown me much so far. When I press A to send an SMS, this is all that I get on the monitor - the “#” is me masking my real number (selected from contacts to save myself typing, hence “pressed3”; “contactID”; “-1”), and “HI” is the actual message I sent in all caps:

Cursor: 0
chosen: -2 
AT+CREG?

+CREG: 0,1

OK
pressed3
contactID
-1

AT+CMGS="+###########"

> 
HI

At this point, the message is actually received by my other phone, but it doesn’t look like a response was processed as being received from the network…we hang on “Sending text…” forever. Still could be timing, as previously mentioned, or perhaps some EOL or EOM is not being sent and the network is the one still waiting? I don’t know what IS or ISN’T being sent to the serial monitor.

And now on to Calls… When I place a call, here is the serial monitor output from the moment I press A:

AT+CREG?

+CREG: 0,1

OK
call id: 2

Then it hangs on the “Calling…” screen until it times out and shows this:

ENDED
Direction of call: 1

Nothing else shows in the monitor and it just returns to the dialer screen. I hope this helps somehow!

EDIT: Alright. Now that I figured out how the SIM module debug works in tandem with the Serial Monitor, I have new information. We seem to be getting held up around line #1063 of /src/messagesApp.cpp

Since the SMS is actually sending out to the other phone (and is received), we know the ESC is making it to the module. If I manually run the commands to send myself an SMS via debug, I get the following (again using # to mask my real num):

AT+CMGF=1
OK

AT+CMGS="+###########"
> Hello

+CMGS: 25,"20/06/07,03:29:18-28"

OK

Of course, I currently have no way of knowing what messagesApp is actually receiving back, as this is not sent to the serial monitor, but I don’t think it is receiving what it is expecting to receive and this causes it to get stuck in the while() loop.

Ting seems to be working fine with my Ringo and v1.0.5 firmware so far (I’m located in NJ, USA). I’m not certain whether it is using 2G or 4G.

I am able to send/receive calls and sms. Sometimes reception is weak in certain parts of my home, but it is strong outside.

I do occasionally get a network module not inserted error when returning to the main menu from a game. I usually power cycle my phone to remedy the issue (restarting doesn’t fix it). I haven’t tried toggling airplane mode but will try that next time it happens.

@delpozzo When you go into Settings > Network, what are you seeing as your Signal Strength? Just want to get a baseline comparison since the reported RSSI can be wildly variable depending on the tech being used.

Also, are you Arduino proficient at all? I’d be curious to see your Serial Monitor output during things like sending SMS and placing an outbound call to see if anything different comes up for you versus what I’m seeing. Showing the monitor is pretty simple, if you aren’t familiar:

  1. Launch Arduino with the Ringo connected via USB
  2. In Tools menu, ensure the proper Board: “Ringo by CircuitMess” and Port: “COM# (Ringo by CircuitMess)” are selected…you may need to follow these directions to install the necessary Arduino addons
  3. Again, in Tools menu, select the Serial Monitor
  4. Set the Baud in the lower-right to 115200

Once you start interacting with Ringo again, you should start to see debugging info show up in the Serial Monitor. This is what I would like to capture:

  1. Go to the Phone app and enter a number or select a contact…but do NOT send the call yet…
  2. In the Serial Monitor window, click the Clear Output button so we can isolate just what we want to see
  3. Now send the call. Once connected and you can hear the other end, hang up
  4. Now you can copy/paste the entire output to a notepad application on your PC for sanitation. You want to mask any real phone numbers it contains. Just use # in place of each digit you are masking

You are welcome to post here or message me the file directly if you’d like. I’d love to see what a working Ting call debug looks like. Same with SMS sending…capturing only from the point where you are pressing the send button and ending after a “Text sent!” confirmation.

If you are REALLY familiar with serial monitor and such things, I can walk you through the manual AT commands and how to work with the SIM Module Debug to get a more complete output of the module’s process - debug output from within apps is quite selective, while SIM Module Debug shows all data coming from the module but requires all AT commands to be sent manually.

@TheWebMachine here is what my output looks like, hopefully it helps!

Settings->Network Signal Strength: 7

Making a call serial output:

AT+CREG?
+CREG: 0,1

OK
call id: 1
ENDED
Direction of call: 1

Sending a txt serial output (“TEST” to +1##########):

AT+CMGS="+1##########"
> 
TEST
cmgf checking

AT+CMGF=0
OK
---------

AT+CMGF?
+CMGF: 0

OK
---------
Prevcursor: -1
Cursor: 0

@delpozzo Thanks! Unfortunately, there’s very little verbosity, so the basic output isn’t giving me anything additional to work with. We’d have to do the SIM Module Debug method and sending everything manually to the module. The only real caveat is showing you how to send a proper ESC character to end an SMS message string, beyond that, it isn’t that complicated.

I could write a small testing app to do the heavy lifting, but a bug results in us losing cellular connection (requiring hard power cycle or airplane mode) when we launch into an app and homePopup() doesn’t give us access to Airplane mode…so I’d basically have to fork the entire firmware to do what I really want. Of course, I’m already considering this. :innocent:

I’ve replied in the other forum topic - we’ll try to sort this out!

If anyone else has the same problems with you that would help us diagnose it, but so far it seems to be a bad network module. No worries, we’ll sort it all out. :slight_smile:

Cheers,
Robert

Btw, what is your signal strength? That could be a part of the problem.

Robert

TWM, this issue has been discussed quite extensively in two other topics here:

https://community.circuitmess.com/t/not-registering-to-mobile-network/3176/10

https://community.circuitmess.com/t/no-signal-what-am-i-doing-wrong/3014/12

The upshot is that for Ting/T-Mobile, the SIM7600A only seems to be able to connect via GSM (2G) or UMTS (3G), not VoLTE. And T-Mobile’s UMTS coverage is a bit spotty in the USA.

@robertCM I am seeing between 17 and 20, as reported in Settings > Network, anyway.

@frankprindle I figured there might be other topics discussing such matters. As I mentioned in another thread, T-Mobile’s support for even the SIM7600A’s 2G/3G bands is spotty at best.

Turns out that isn’t the case, at least where I’m at. I’m sure you were notified of my reply in the “no signal” thread already. :wink:

EDIT: So, it does, for sure, support VoLTE…says so in the spec sheet right on their site:

https://www.simcom.com/product/SIM7600X-H.html (Ignore the X, as that is just a placeholder for the region specific character)

The catch is, the 7600A only supports some of the LTE bands and, while the 7600NA would support pretty much all of them, you sacrifice ALL 2G/3G support. (I recall this being discussed elsewhere in the forum)

That said, @robertCM, if it turns out that switching to an AT&T SIM - my last hope in this region of the US - doesn’t yield better results, are you guys able to swap me for the 7600NA module? Or, perhaps even better, I’d just want to purchase the 7600NA module EXTRA from you** without returning the 7600A so I have both to test with. If you guys are willing to ship me the 7600NA module separately so I can keep this 7600A handy, please DM me a price+shipping and payment instructions. I’d definitely prefer paying to have the extra module on-hand versus having to exchange this one, if that’s acceptable to you.

** (would be easier than me trying to source the right mPCI card on my own in a measly Qty of ONE :rofl:)

Oh, we would gladly do that! Unfortunately, we do not have any 7600NA cards since we’ve decided to go with the 7600A in the US. Only two other versions we have are SA (South America) and E (Everywhere else). :confused:

Getting that one would actually be much easier for you in the U.S. than for us in Croatia. :sweat_smile:

For any other additional parts, we are more than happy to send out to our customers for a very cheap price, but unfortunately, this is something we just don’t have.

AliExpress may not be the most reliable option but sure is the cheapest one.

Robert

Roger that! I’ll keep looking. I just want to make sure I get one that will be an exact drop in replacement for the current module. These mPCI mounted modules are “standard” right?

I thought there was some talk at some point (another post I can’t seem find right when I’m looking for it :man_facepalming:) about how the slot on the mainboard had certain pins bridged because they were common grounds or something but that it might not be the exact same on each SIM7600 model? I just don’t want to get the wrong “variant” of an mPCI mounted 7600NA and permanently damage the mainboard or module. Any advice to help properly narrow down my search would be greatly appreciated!

@TheWebMachine not sure if this helps, but I just received the following email from Ting:

Hi there!

As you may know, we recently added America’s largest and most reliable network, bringing our total number of networks to three! That means that new customers can be placed on the network that will offer them the best coverage and best suits their device.

One of our main goals in adding a new network, though, was to improve coverage for our existing customers. If you’re experiencing any network issues, we encourage you to contact our support team. After checking your location and device details, we may be able to put you on another network that will work better for you.

As always, our goal is to provide you with the best cellular service at a lower price. We look forward to maximizing your experience!

The Ting Team

It looks like if you call customer service they are able to put you on another network (I assume they may need to send you a new SIM card to do so, but I could be mistaken).

Ting is adding Verizon availability. Sadly, Verizon not only sucks down my way, their network isn’t well supported by the SIM7600A.

I have made progress (towards enlightenment, anyway :man_shrugging:) on a few things in the last 12 hours. I’ll get a post up with the details soon. There’s a lot to unpack and I’m still testing a few things to be sure. I’ve determined that I have had no less than 3 completely different factors working against me, hence the difficulty in nailing this all down. :expressionless:

2 Likes