No SD Card access... DIY makerbuino

I realise that I shouldn’t expect any help as this is a DIY build, but this seems like a friendly community and maybe someone would like to help. Thank you if this is you!

The background to this build is that my 4yo son asked if I could make him a computer - I looked around and with only a few days before a long trip, a DIY makerbuino with some of my spare components looked like the ideal project to try this. I’m reaching out for help because I want to use this as an opportunity to start an interest in technology with him.

Here’s the front:
And here’s the back:

The setup is a 4way joystick to do direction buttons, with button C temporarily using the centre-push button of the joystick. Buttons A and B are the momentary push ones on the right. The Arduino Pro Mini 3.3V has had a resonator changed to make it 16Mhz, as per the specifications of gamebuino/makerbuino. The SD card reader has a voltage level converter to allow use with 5V systems but I have bypassed the 5V input and soldered 3.3V straight to that rail.

I have no problem uploading the bootloader to the Arduino (it took a while!) anymore. I can upload Makerbuino sketches (Loader.ino, a_Hello.ino, c_Controls.ino etc) to the arduino through the arduino as ISP method (but can’t get sync with FTDI programmer for some reason). I have LOADER.hex and SETTINGS.hex on a 2GB Samsung micro SD card which has been formatted to FAT (16). I have powered from the lipo battery on the SD card regulator, another Arduino’s 3.3V regulator and 5V to the regulator on this Arduino. I have not attached any sound or LCD backlights at this stage, to avoid voltage drop issues - it’s just the arduino, LCD and SD card reader (notice 100uF cap on the supply to the LCD). The SD library example sketch can also successfully read the SD card in this DIY makerbuino, so I am really puzzled as access and connections to the SD card must be fine.

With Loader.ino installed, I keep getting problems of the makerbuino unable to access the SD card. With no SD card, it correctly asks me to insert SD card and reset. But with an SD card installed, it constantly resets itself, sometimes eventually stopping and asking to insert SD and reset: VIDEO:
With other sketches installed, they never enter the loader mode/SD mode when C is pressed or pressed during reset and then released.

Any suggestions that people have, I’d be very grateful to hear. Happy to take advice on known-working combinations of bootloader/sketch/SD-contents, as I have collected several versions from around the web to try an solve this.

Thanks for reading this far and double thanks if you can help.

So here’s what Arduino thinks of the SD card. Seems ok to me. I have now replaced the SD card module with just an adapter, such as this,image connected directly to the pins of the Arduino. Still no joy, so I don’t know what to look at next.

Also should say I have modified two Arduinos and tried with both, to check it’s not the particular chip/board causing issues.