Not registering to mobile network

I have a maker phone that cannot register on any mobile carrier network to make a call or text. I have tried multiple sims with the same result. The phone will either not recognize the sim, just says loading or flashes in and out of signal.

For the record, I have verified that I am inserting the sim correctly with the notch facing top left away from the unit.

If I am able to get the sim to be recognized, I am able to get a list of providers with the sim debug tool. However, the icon on the home screen just says loading.

The signal strength will be from 0-20 and occasionally 99, but mostly 0. I have reseated the antenna and 4G network card with no change.

I have tested with an Ultra-mobile sim, that works in a Samsung, a Simple mobile sim that works in a Samsung and my T-mobile sim that works in a Pixel 3.

I have done multiple resets and setup wizards and traveled to where the cell towers are near my location and tested all the sims with no successful result until the battery died.

I have been able connected to Wifi and downloaded any updates, however it was already at version 1.0.1.

This phone was already sent in for a “faulty IC on the mainboard” and repaired shipped back half-way around the world.

Any help will be appreciated.


I am really sorry to hear this and I’ll help you make your MAKERbuino work.

Can you please send me a private message with the email you’ve used to speak with our support stuff so that i can check what happened and proceed from there?

I sent an email to Erik since I couldn’t find your DM contact.

Thanks, we’ll reply there and get this fixed.

thank you for your patience!

I have same issue of not connecting to Network. I have tried 3 providers in the US, Ting, T-Mobile and AT&T. Once the SIM is connected I get a Welcome text from the provider, I get a test call and once I leave the phone stops connecting, the screen shows “Loading”

I have 3 of the 4G Ringo phone, 2 assembled by me, and the last was bought pre-assembled

Thank you for supporting our work in such a large quantity and I am sorry that you’re having trouble with the network connection on your phone.

I’ll help you out with this. Can you please send me a private message (you can do this by clicking on my profile picture).

Please, tell me more about your problem with this.
Did you experience this problem on all three phones or only on the assembled model?

Thank you very much and I am sorry for the inconvenience caused

I am having a similar issue. The SIM is installed correctly. Ive tried two different carriers (Ting and T-Mobile). I don’t get any signal. Just this message:

Registering to Network…Network unavailable, Try again later

The phone is in the US and has a SIM7600A chip which I believe is 4G. I made the phone with my 11 year old daughter. We had fun with the assembly but she wants her phone to work :smile:

The phone connects to WiFi and has been updated. Any suggestions are welcome.

Hey, thank you for supporting MAKERphone and I am sorry for the problems that you’re having.

Please, can you reach out to via email and we’ll help you out ASAP?

Don’t worry, we’ll get this sorted out

I had exactly the same problem with Ting and T-mobile. Put an AT&T SIM in the phone, and it worked perfectly. Go to an AT&T store and see if a salesperson will let you try a SIM out of their personal phone. Worked for me.

1 Like

@kfixman Thank you! AT&T SIM did the trick. We have a very happy girl at home.

1 Like

Just a hint to see if your area perhaps doesn’t have adequate Ting/T-Mobile coverage (in the USA). Go to this web page:
T-Mobile coverage map
Enter your city/town name to zoom in on where you live (zip codes don’t seem to work), then zoom/pan further and click on your approximate location. You should get a readout of coverage in your area. Look at 2G GSM 1900 if you have a 2G module, and 3G/4G UMTS 1900 if you have a 4G module.

It’s fine (at least the UMTS is) in my area, but I tried (for example) Big Horn, WY, and neither GSM nor UMTS coverage is provided there (not a big surprise since the town is all of 16 square blocks :slight_smile:).

N.B.: In fact, you can enter your whole address, (street number, street, city, state) to zoom right in on your residence.

1 Like

@jdobrick I’m glad that this works now!
@kfixman, thank you for helping out here.

@frankprindle. Thank you. T-Mobile in my area has 3G/4G UMTS 2100 but not 1900. 1900 is used for 4G LTE which I guess isn’t supported by the SIM7600A 4G module that came with our phone. AT&T seems to be working fine

1 Like

Interesting. T-Mobile in my area has 4G LTE 2100,1900,700,600, plus 3G/4G UMTS 1900 and 2G GSM 1900. With all of that, the phone only works with the AT&T chip.

Look at the signal strength icons on the T-Mobile map for the UMTS 1900 and the GSM 1900. They may show only outdoor coverage at your location.

GSM 1900 is good in all locations while UMTS 1900 is good outdoors and in vehicles. I drove the phone all over the area with no joy.

I also recently purchased and assembled a Circuitmess phone and tried both Ting and TMobile SIM cards. When I go through the setup process, it says the SIM card is OK - so I know I inserted it correctly. But it always says “Loading …” where the bars should be and I am never allowed to connect to a network.

Hello there,

Firstly, thanks for joining the forum and for supporting our project! :slight_smile:

There could be multiple things that are now allowing you to connect to the network.
As you said that you’ve inserted the SIM card in correctly, I would say that is done correctly.

One of the most common problems is the soldering - please check if you have any residual solder left somewhere on the board and if all of the soldering joints are properly done! This is the most important step.

Secondly, make sure that the antenna is connected to the 4G module on the MAIN connector, and that the antenna is properly placed in the cutout.

Finally, did you activate your Ting/T-Mobile card? If they are brand new cards, they require to be activated either by sending a message or by making a call (not quite sure which network uses which method). You can also try calling or sending a text to this mobile number in order to get that first connection. Even though it says loading, it doesn’t have to mean that the connection isn’t there, just that the network cannot reach the name of the service provider at the moment.

Please try these methods and stay in touch! :slight_smile: