Odd behaviour on first power-up

Hi - first time I’ve built one of these and I’m geting some slightly odd behaviour when I try and power it up for the first time. I’ve experience with soldering and all the connections I’ve made appear good - but I must admit I didn’t test all the caps before soldering them in.

Anyway, I’ve got the first power-on stage in the instructions and what’s happening is this:

  • No activity when I flip the power switch.
  • If I turn it off and leave it for a few seconds, then try again, it also still doesn’t power up.
  • If I turn the power one, then off, then on again quickly, then the system powers on and goes to an adjust contrast screen.
  • When I power it off then, the screen blanks, and shortly afterwards, a single, broken horizontal line appears briefly on the display.

Pretty sure that the electrolytics are all soldered the right way around and I haven’t got the VR and transistor mixed up.

Any ideas?


Can you post some pictures of your soldering?
My only idea (if you leave out the soldering joints) is that your MCU might have a damage.

Unforutnately, my phone doesn’t have a useful enough macro mode to take useable photo’s. (I did try!).

I’ve tried adding C01 - the 100nF cap between VCC and GND which feeds the CPU, but that hasn’t made any difference. Given the repeatable behaviour of it starting up after rapidly switching the power on/off once, I’m working if one of the electrolyic caps is faulty or the oscillator isn’t starting properly. Any way of checking those caps, or the crystal without desoldering them all?

Is there a way to check if the clock circuitry is running properly when the CPU isn’t running?


You can check the oscillator if you have a multimeter which supports frequency measurement: https://sciencing.com/test-crystal-oscillators-8728348.html
You don’t need to desolder the oscillator this way :slight_smile:

Checking caps without desoldering will most likely give you false results.

I’ll give that a go - I had a feeling that trying to measure the direct output from a crystal was likely to stop the oscillations anyway - clearly it’s workjing sometimes else I wouldn’t see the CPU start ever?

Can you go on after you’ve adjusted the contrast of the screen?

Dunno - I haven’t soldered in any of the buttons yet. Somewhat more worried about not being able to properly turn it on yet.


Ah okay, totally understandable :slight_smile:
I’m curious what kind of result the oscillator measurement brings up! Keep me updated! :slight_smile:

Okay - so I decided to desolder the screen from the mainboard - took a while, but got there in the end.

After that, I double checked my soldering of the DIP socket. Tested continuity of every line back to the next component according to the schematic and all was good. So - not an issue with my soldering of the DIP socket.

The sockets in their for pin 1 and 2 did look a bit more widely spaced inside than thje other pins - this did give me some brief consider that the reset line on the CPU was getting an intermittant voltage - but, no, repeatedly turning it on and off the voltage was steady on pin 1.

Putting the scope on the SCLK line gave me a ~250kHz square wave for about 6 seconds before dropping to zero volts. I do see a continuous high frequency signal from the crystal (at about the limit of what my old analog scope can measure) - so I’m guessing that’s happy at 16Mhz.

Of course, I could now redo all the soldering and reisntall the screen - but I’m not convinced it’s working still. Any thoughts of what I can do diagnostically before re-soldering the screen?


The continuity test result and the crystal test result are sounding great as far as I can tell, but this is causing me a headache:

6 seconds are way to long for a transmission of a single image. Given the fact that the MAKERbuino runs at 20fps usually this is a pretty odd behavior. So I guess that the MCU is sending about 120 images before an error occurs.

How are you powering your MAKERbuino? Are you using the battery or an external powersupply while testing? Have you measured the voltage of the battery? Maybe it’s almost empty.

There are only two possibilities I can think of right now:

  • Your MCU is faulty or something went wrong while flashing the contrast setting program
  • Your Display is faulty. But that wouldn’t explain why SCLK stays LOW because this signal should be delivered by the MCU

Maybe @albertgajsak has another idea or an explanation but he’s currently visiting the Maker Faire Rome according to MAKERbuino’s social media channels.