Possible defect ATmega328? [SOLVED]


I received 2 MAKERbunos and build them without troubles.
The first one worked right away without problems, but the 2nd one worked for some minutes and now it does not display anything on the screen. Just the light gets up.

I exchanged the ATmega328 between the 2 MAKERbunos and the problem goes with the ATmega328.
So either the chip is damaged or the firmware is.
I tried the hardreset with button C, but that does not work.

I read about the possibility to flash it, but neither do I have an Arduino Board nor feeling I’m up to do all the procedures including the breadboard.

Any suggestions on how I could proceed?

Thanks, Chris

Hi @Sejin,

I have messed a lot with my atmega328 (flashed a game several times with the programmer, being unintentionally disconnected while flashing a couple of times, unintentionally turning it off while changing games…) and it is still working fine. Did you do the C button trick right? You should keep the C button pressed while turning on and keep it for 1-2 seconds, then release it and wait up to 25 seconds for it to flash the game loader.

I would also suggest to check the sd card and sd card socket, since the game loader is loaded from the sd card every time, but if you have changed the atmega between the two makerbuinos and the error has gone with the same atmega, this should not be the case.

1 Like

@ladbsoft, you’ve given an excellent and thorough piece of advice to @Sejin!
@Sejin, I think that you’ll just need a C-button reset trick as @ladbsoft already said.
Please try it and update us with your progress.


I’m writing this somehow puzzled but also happy because my issue has been resolved.
Initially I was going to write an answer to @ladbsoft and @albertgajsak pointing out, what I have already written in my initial statement, that I have tried out the C-Button trick multiple times.

Nevertheless, to show good will, to be on the save side and for gods sake I tried it again this evening. Only this time I switched the ICs between the 2 boards (again). And caught by surprise this time it really worked!

So, I now have no idea what happened initially, nor why it did not reset the first dozen times I tried. But now it did and the thing is working.

Thanks to both of you replying to my request (and probably crossing fingers).

1 Like

Interesting, is the C button on the second unit defective? That’s the only thing I can think of.

1 Like

Well that would be too obvious, right?
That’s the reason I checked that right in the beginning. So I exchanged the chip with my second buino and confirmed that both C-Buttons are working fine as well as all other functions.

1 Like

@Sejin, I am not sure what happened, maybe there was some dust or other unwanted particles in the SD socket and you were switching SD cards so you’ve removed that and made the contact with the SD card better.

Anyways, I am glad your MAKERbuinos work now!
Pics or it didn’t happen :slight_smile:!