Ringo Update #2 - CircuitBlocks and new firmware update!

Hey everyone, :wave:

This update is a pretty big one so buckle up! :seat:

We’ve been getting a lot of messages lately on all the platforms and that tells us that you really care about this project. We’re really trying to reply to every single one of them as soon as possible, but there are so many of them!

Don’t slow down though, every question/criticism/advice comes in handy and makes our whole project better so thank you for that!

Now for the updates, here it goes:

  • CircuitBlocks is finally launched. If you don’t know yet, it is our own IDE in which you can program your own things for Ringo. It looks pretty cool and it’s scratch-based, so it’s pretty simple as well. You can also easily revert back to default Ringo firmware via the button which is located on the main menu at any time.
    Here are a couple of images of how it all looks:

    You can download it via this link and check out the tutorial here. :arrow_down:

  • New firmware version 1.0.1 is also up. You can get that by downloading the CircuitBlocks and pressing the magical button, by updating your firmware over the phone Settings -> About & Update -> Check for Update, or by using Arduino IDE via Tools -> Burn Bootloader, just make sure you have set Programmer to ‘Ringo firmware’. To get a new update on Arduino, you have to update Ringo board files by using the Board manager. Just scroll down until you find Ringo by CircuitMess and update to version 1.0.3, then use the bootloader.

  • Some of the improvements in the 1.0.1 update are updated Wi-Fi password length, added ‘$’ sign on the button 0, fixed calling issues and other various fixes throughout the phone. :dollar:

  • We have also added Ringo by CircuitMess library on Arduino IDE which now means that you can use library functions in Arduino. To download, go to Sketch -> Include library -> Manage libraries and type Ringo in the search bar. Then click the Install button. The list of all functions and keywords is still not available so we do recommend using the CircuitBlocks IDE since everything important is easily accessible there.

That is pretty much it, continue to give us suggestions and we will continue to improve everything as much as we can.

Keep on making, MAKERS! :building_construction:



Dear Robert, I am not able to make the CircuitBlocks work. It does not update to the latest firmware and does not upload my „Hello world” code created by CircuitBlocks editor. It shows my Ringo is connected until the moment it tries to upload data into the Ringo. Then it disconnects with some vague error message („not able to upload, check Ringo”), and Ringo needs to be resetted and restarted to work again. What to do? Thanks!

PS: using Mac (dmg) version of the CircuitBlocks.

Dear Robert,
same issue as tombarys using Windows.


Dear Robert,
same on Linux Ubuntu. I installed CircuitBlocks (1.0.1) and tried to update from Ringo Version 0.9.9 to 1.10.1. By click the “Restore Ringo Firmware” Button I get the message: “Upload Error. Check your Ringo and try again”. Ringo is connected and after that turned off. Firmware Update via “Check for update” ends with a reset to the current Version 0.9.9- Btw. Ringo does not save the WLAN Password?

Best regards

Some impressions I had so far:

  1. There’s an error when you’re running circuit blocks on windows 7 for the first time when your username contains a space. When CB tries to install the Arduino CLI it will throw an error cutting the command it was trying to execute right after the space of your username.

  2. Windows 10 + Google Chrome is going nuts over your file. Google Chrome blocked my downloaded copy of your windows installer exe-file, because it’s from an unknown source. When I tried to run it on a Win10 machine, Win10 told me that it will block this exe because it’s from an unknown source and I need to unblock it. Of course that’s not a problem for me, but someone who has less experience might get intimidated.

  3. Last but not least: the location of the installation. Why isn’t there any way to change the path of the installation? I don’t know if I’m the only one, but I don’t want to clutter up my SSD. Is there any chance to change the location? Or do I need to build CB manually then?

Greetings :slight_smile:

@Yves We’re looking into that - on every computer it worked fine for us but a couple of users are complaining about the same error. As soon as we fix it, we will release a new version, expect it to be as soon as possible.

It is very strange that it goes back to the Version 0.9.9 - do you get the ‘getting new update’ screen? Maybe it does not connect to the WiFi successfully.
Yes, as of right now, it does not save the password, but that is something that is going to be fixed in the upcoming updates (there isn’t much use for WiFi besides update anyway so I hope this isn’t a big problem right now).

Thank you for such a comprehensive update! These are all errors that we are aware of, as some of the users have experienced it in the last couple of days.
About the third point - we really wanted to make it as simple as possible for the users by not having to worry about these kind of things since it doesn’t really take up that much space, but we are definitely looking to implement the change path part of the installation in the next update!

Yes, i m getting the new update screen “UPDATE AVAILABLE Version 1.10.1 Press A to start update”. According to my Router, Ringo ist connected to the WiFi successfully. The Update Process starts Downloading and says Install. But after Reset, the Version is stil 0.9.9.

Maybe there is a problem with the SD card.

Can you try putting a different SD card in (just make sure it’s not over 16GB) and try to download it again? Corrupted card or files on it seem to mess up some of the phone’s functionalities.

Thank you very much for considering this option for future updates! I know that CircuitBlocks doesn’t take that much space but I like to keep things tidy. I’ve got extra partitions on my Win7 Desktop and my Win10 Laptop where I keep my developing related stuff :slight_smile:

1 Like

I see references in this topic to Ringo firmware version 1.10.1, and when updating from 0.9.9 over WiFi, it says “UPDATE AVAILABLE! Version 1.10.1”. But after the install is complete, it says the version is 1.0.1. Which is it, 1.10.1 or 1.0.1?

I also notised that but I did double check on github to see what they did and found that the
old version was not able to show the new version correctly (it showed v1.0.1 as v1.10.1).
That was however corrected in the new version that you downloaded.
So that’s why you now see it as v1.0.1 now, so you have the latest version.

See commit https://github.com/CircuitMess/CircuitMess-Ringo-firmware/commit/1549e9214ed9486a96b3fc140ab36c6f007f47c3

1 Like

Aha! Thanks. I kind of thought that was too big a jump in version numbers for one update cycle.

@frankprindle @Blixten
Yeah, the initial firmware was showing verions numbers wrongly
Sorry for that

Any Mac users here? Neither Finder nor CircuitBlocks seem to recognise my Makerphone connection when I connect it by USB.

I tried to connect it when it’s already on, and also tried switching it on while connected.

I’m on Mac OS Catalina. What steps am I missing?


Does any of your USB ports recognise that a new device has been inserted when you connect MAKERphone?

Macs are known to have some issues with the USB connections. Does the phone charge when you connect it?


Hi Robert,

Just now I figured out what my problem was. I was using one of my own micro USB cables, which charged the phone but couldn’t connect it. When I used the cable supplied with Makerphone, my Mac recognised it (CP2104 USB to UART Bridge Controller) and so did CircuitBlocks.

Looking forward to see what coding I can do with it!


1 Like

Yeah, that’s a problem with micro USB cables… you can’t visually tell which ones are “charging only” and which have full USB connectivity. You just sort of have to keep them in separate drawers. :upside_down_face:



They are a bit tricky. All the cables we’ve sent you should work well so keep that one somewhere close or mark it with a tape so it doesn’t get lost in the pile!


I’m encountering problems with uploading the firmware, too. At least on my development laptop (win10, Arduino 1.8.10 and CircuitBlocks 1.0.1). My Ringo gets recognized within CB but when I try to update the firmware it says “Upload Error. Check your Ringo then try again”. The Arduino IDE is unable to flash it aswell. It says

java.lang.NullPointerException at cc.arduino.packages.uploaders.SerialUploader.burnBootloader(SerialUploader.java:329)
at processing.app.Editor.lambda$handleBurnBootloader$65(Editor.java:2394)
at java.lang.Thread.run(Thread.java:748)
Error while burning bootloader

I’m using the provided micro usb cable, so this can’t be the fault.

I’m also encountering problems with uploading CircuitBlock-Programs to the Ringo. Even the “example sketch” on this website is throwing a compiler error.

Haven’t tested this on my PC yet, as CircuitBlocks throws an error during the installation.

*€dit: I’m able to upload the example program to my Ringo, if I copy the code generated by CircuitBlocks into a new arduino sketch. But of course I can’t return to the main menu.