Screen doesn't show anything anymore

So I finished my Makerbuino and it worked perfectly fine until I tried to load a game. The screen went white and doesn’t show anything anymore. Turning on and off doesn’t help. Everything worked perfectly fine until I tried to load a game.

Have you tried the C button trick? Turn off the MAKERbuino, press and hold the C button, turn the MAKERbuino on again and hold the C button for another 2-3 seconds. Release the C button and wait ~30 seconds while the game loader is being flashed.


Yes I did try this and it doesn’t work for me. The device worked perfectly this morning. I used it twice, turned it off and on again and then the screen didn’t work anymore. I checked all the joints and there is nothing wrong with any of my soldering.
The sound works and i can hear the games starting when I press the buttons. It’s only that the screen doesn’t show anything

are you sure that your battery is always charged ? Maybe a problem to fill it ?

1 Like

@Nicolas_Welsch, I am sorry that you’re experiencing problems like this.
I didn’t see your post before and I hope you didn’t give up on this. In case you have a problem with your buino, you’d also want to try sending us an email or tagging me with @albertgajsak.

Try reinserting the SD card a couple of times and blowing in the SD socket real hard (that cleans the dust particles, and believe me, it helps in some cases).

If that doesn’t work, post some photos of your buino’s front and back without the casing installed.

Don’t give up!