Screen suddenly stopped working

Hey everyone,

So my MAKERbuino worked great for about a week but suddenly the screen stopped working. The backlight, controls, and sound all seem to work as I can hear games being played in the background and the appropriate sounds being made when buttons are pressed. I can also press C to get back to the loader, the loader startup sound plays after a few seconds elapse as normal. Sometimes the screen comes on briefly when the power is turned on but then quickly goes off, or only stays on until a button is pressed then goes blank. Some things I’ve tried:

  1. Reheated some iffy-looking solder points
  2. Tried the C-button reset
  3. Reflashed the MAKERbuino via Arduino IDE and USB. This worked and games from source were successfully flashed but the screen remained on only briefly before going blank again.
  4. Replaced the AVR chip with one from an Arduino UNO and reflashed. Same results as number 3.
  5. Recharged and tested battery voltage. It is reading 4.08 Volts.

I’ve attached a few photos of the board with different lighting. Any help would be appreciated!

Thank you.

OK, so I had the some problem and in my case, it was the battery. So try resoldering the battery joints. If that doesn’t help, try re-inserting the SD card slowly. If none of these work, try charging it overnight. Really hope your device gets fixed! :+1:

@ante thank you for your quick reply, I really appreciate the help. I just tried your suggestion and re-soldered the battery joints but no luck. Not sure if this matters but the BAT+ and BAT- on the blue LiPo charge board (front of the MAKERbuino) reads 4.08 volts. I also tried carefully re-inserting the SD card but that didn’t work either. Of note, my MAKERbuino typically makes it to the game selection screen (all game tiles load) and that is about when the screen goes blank, either within a few seconds by itself or immediately after pressing any button. I will try an overnight charge to see if that helps.

I don’t think the board matters because your device can turn on. If it still doesn’t work after charging, try resoldering some bad joints. The last resort would be trying to test another battery or if you don’t have one, buying one. But maybe you should wait for other advice before buying a new battery.

1 Like

I went for the overnight charge, in the morning the charge light had turned from red to blue. Still no luck, same screen symptoms. Good idea about trying another battery, I happened to have another 3.7V LiPo battery so I charged that up with a separate LiPo battery charger. My MAKERbuino fired up with the new battery but the screen still goes blank soon after startup. I’m fairly confident now that the issue isn’t with the battery. I also tried reheating a few more solder points but no effect. If anyone has any other ideas I can try out please let me know.

Thanks again @ante for your advice, at least we ruled some things out!

1 Like

@delpozzo, thank you for supporting MAKERbuino.

This is quite strange as your soldering joints look perfect… I think the problem might be caused by the screen itself (i.e. it somehow got broken internally and stopped working properly).

I’d give it a go with a new screen and there are two options for that:

  1. send me your MAKERbuino and we’ll change the screen and debug it for you
  2. we’ll send you a new screen and you’ll have to replace it yourself - desoldering the screen can get tricky and I’d suggest you go with this option only if you think you can handle it

Tell me what you think via private messages.
I’ll help you solve this, sorry for the inconvenience caused.

@delpozzo when reflashing the atmega what fuse and lock bits you are setting? i had the same problem, when those variables wore set wrong. So it would work, and then after certain number of key presses it would just white out the screen. After i discovered correct values, problem was eliminated.

@albertgajsak, @delpozzo in my case i used these parameters. I used USBasp programmer, but regardless which one you use to flash your chip you should set these somewhere.

@gillwiz thank you for your reply! I never tried re-flashing in the manner you described but that is very interesting and something I will keep in mind. I had simply uploaded a game I’m developing via USB from the Arduino IDE directly to my MAKERbuino. With that said, I may have used the wrong term when I mentioned re-flash in my earlier posts :thinking:

However, I sent my MAKERbuino to Albert and thankfully he was able to troubleshoot the problem. It turns out the screen itself was defective and a screen swap solved the problem.


@delpozzo when buying new atmega328 chip it comes empty. And if you would upload directly it would have not configured to use external oscillator (which by default it uses internal, which runs as i found out at 1MHz). Problem, i had. But, as mentioned before, i used USBasp to program it, and Arduino IDE, with imported board configuration have those settings pre onfigured to be the right ones. Good to know, that everything works now :slight_smile:

1 Like

@delpozzo @gillwiz, yeah, the problem was in the screen itself (Nokia screens tend to just randomly die in some special cases).
I was quite sure that this didn’t need reflashing since @delpozzo said that:
a) the picture suddenly stopped appearing
b) the sound was still working —> very important as it means that the microcontroller is still working properly

Anyways, @delpozzo should have his MAKERbuino back soon. @gillwiz, thank you for the advice