Sending Code from website to Board

I know this should be very simple but I haven’t been able to send my code to any board I’ve tried to program so far I use both Linux Mint and windows 11 Duel boot (prefer Linux) I have used a few different browsers including chrome but I’m unable to detect any of your boards at least not the few I’ve tried have I have only tried to send code to the Bit so far but have used many different programing setups over the last 26 or so years including Micro controllers over the past 6 years do I need an agent program on my pcs or some sort of special drivers.
I have some complex Brain health issues so I might have missed something obvious. Is there a tutorial for setting up the computer or browser so it will work

1 Like

Hi @kiera,

sorry to hear about this.

Can you let me know if your device is working properly besides the coding part?

If not, please send us a few photos of the device (back and front, without the casings) so we can check it.

Thank you!
Monika

the Bit is the only board I’ve used successfully with out programing that I haven’t been able to code. most other boards I haven’t tried to send code to.
should I send photo via email or can they be posted on this forum?


the front and back photos are above I’m unsure if you can see the red line on the display that line might get annoying but Since I can’t connect it is a mute point. I have tried to connect to spencer and Clock Star in there raw state (Just the main board with no components soldered in) just to see if they will connect no sign that they are connected I’ve done this on my windoze 10 computer (desktop) while my duel boot win11 / Linux Mint machine I’ve only tried to connect the Bit Unsucessfully.
I have built the Bat Controller and have the same issue as the other boards

As a new member of the forum I’m only allowed to send 1 photo. otherwise both front and back pics would have been attached. just realized the above photo doesn’t show the whole board
Sorry and Thanks

1 Like

Thank you so much for your reply.

I’m sorry to hear about the issue you’re experiencing. Have you tried using a different USB cable to connect your BIT to another PC? If possible, please give this a try and let me know if it resolves the problem.

Thank you,
Monika

3 OSes 2 computers 3 usb cables 2 of the cables came with your products a third cable that I have used to program other devices with my experience I’m thinking that something within Crome or the website that is not right either let me know what settings are required within or point me to a downloadable version of circuit Blocks for linux or Windows. Also is there a tool that enables the OS to see the boards other board makers can be detected by the OS when plugged in. Could there be an issue of permissions within Linux?

I’m finding It hard to pinpoint this error and that is rather concerning for me.

Thanks for trying to help. Hoping something can be done

1 Like

Hi @kiera,

thank you for your reply.

Could you please try to connect to CircuitBlocks using Firefox? There, you will see the option to download CircuitBlocks Agent. Please download it and try connecting again; that app should be helpful while coding in Firefox. Please be aware that this is only for Windows. We do not have a CircuitBlocks Agent available for Linux.

I’ve tried using firefox with the agent. the Agent is detected but still wont connect to to the bit.
I’m thinking If I install micropython and program it with Micro Python would be better then trying to get circuit Blocks to connect to the Bit.(or any other circuitMess board) I have some experience with MicroPython and a fair amount of experience with circuit Python I’m hoping there is a guide in git hub on how to install MicroPython onto the Bit… I’ve just spent a few hours trying to find a guide on how to install micropython If you could send me a link to a guide on installing MicroPython onto the bit that would be great. I noticed in github /circuitMess/a number of folders that have arduino in the name of the folder. If there is a way to setup the Arduino IDE for the various CircuitMess boards (With examples) Then a link to that guide would also be helpful. I’m sure that either of those setups if they work would not have the limitations of visual coding systems(I’ve used a few different visual programing systems). the less text based code is used the greater the limitations

1 Like

Hey @kiera,

MicroPython can be installed on Bit by simply clicking on this part:

However, if your PC does not recognize your Bit, you cannot come to this part.

Here are the instructions for how to manually install Arduino: GitHub - CircuitMess/Arduino-Packages: Contains platforms and board definitions for CircuitMess' devices..

Thanks for this. It shouldn’t be too long before I have a simple game on that thought do you have a place on the forum where we can share projects , games and code that the people of the community can feely share and learn from each others Ideas I know you have a Discord Channel is that a better place for us to share ideas and projects Either way having different areas for Arduino/C/C++, Micro-Python and Code-Blocks. Thanks again.

1 Like

Hey,

that would be amazing!

You can share the project both here and on Discord. Both communities are fantastic, and many people will be interested in testing your idea and brainstorming with you.
Discord is perhaps more active, but feel free to share on both platforms.

It has taken me a while to get the Arduino ide setup sadly the Bit isn’t included in the board definations I noticed that the Bat-Controller is listed under both esp32 and Esp8266 while the BatMobile isn’t listed under either. Are there special Libraries for the different boards or are there libraries based on the various hardware that is needed to include to use the different hardware display, buttons etc. I do have the Bat Mobile what version of the Bat-Controller should I use?

Hi,

Unfortunately, at this moment, Arduino IDE can’t be used with Bit, but we are working on it.

Regarding your Batmobile and Batcontroller, you need to use an older version of Arduino IDE (1.x and older).

In File → Preferences (in Additional board manager URL), put this link:
https://raw.githubusercontent.com/CircuitMess/Arduino-Packages/master/package_circuitmess.com_esp32_index.json

Then, go to Tools → Board → Board Manager and type “CircuitMess” into the search bar.
You will find the CircuitMess ESP32 Boards package.

When you install it, you should have both Batmobile and Batcontroller available.

Best,
Sandi