Sluggish/slowmotion performance of makerbuino [SOLVED]

So, i soldered everything, preloaded the bootloader, got the contrast screen. Everything works, except everything is like in slow motion. All games run very slow, response is slow for the buttons. And i have no idea why. Used atmega328P-PU chip, the only difference from the original schematic is that i used 16V100uF capacitors instead of 6.3V100uF ones. Any ideas are welcome

@gillwiz, welcome to the forum.

Why did you preload the bootloader? Did you follow the instructions on

The bootloader comes already preloaded on your kit’s ATmega328p-pu microcontroller and there is no need for reflashin the thing.
Why did you use the different capacitors? Did the ones in your MAKERbuino kit break? You should’ve sent us a support request and we could’ve given you the replacement capacitors for free.

This sounds like some kind of a microcontroller clock issue… I think it has something to do with the bootloader (i.e. some fuse bits not being set properly and thus, everything is running on a clock speed slower than 16MHz) or the quartz crystal on your device.

Please, give us some extra info and pictures, we cannot help you without that.

thanks for the prompt response. i loaded the bootloader because i had blank microcontroler. I had blank microcontroler because i used your schematic, and got pcb printed. So… yeah, amazing project, and maker in me wanted to replicate it. :slight_smile: same reason for the capacitors being different, just had same value but higher voltage in my parts bin.

@gillwiz, thank you for the praise and congratulations on making your own board design :slight_smile:

As I said before, this must be some kind of a clock issue, please check the crystal on your device and the corresponding capacitors that form the oscillating circuit.
Also, which bootloader did you flash?

not sure, found here

crystal is 16.000 so, only electrolytical capasitors are different from your schematic. And well i loaded bootloader with usbasp programmer, and have not used it for like 5 years, so not sure if fuse bits needs to be changed.

You’re using the right bootloader.

As to what is causing this, I have no idea… perhaps some of these components are defective:

  • crystal
  • 22pF capacitors
  • microcontroller

my guess is that it is using the internal oscillator and while loading the bootloader, i am not setting correct values for bit fuses. And as far as i am investigating, internal speed of oscilator should be around 1mhz, which would work 16 slower than it should. And it seems that way. Now i just need to find how to set fuse bits for it to use external oscillator, since 22pF capasitors and crystal should be fine.

Update… your initial guess was right, fuse & lock bits wore set not correct. Now it works like a charm. Thank you for the right dirrection :slight_smile:

1 Like

No problem, I’m glad that the thing is working now :slight_smile:

I’ll mark the topic as [SOLVED] and see you around at the forum :wink:


1 Like