Spencer Mac connection issues

Hi!

Finished building our Spencer a few weeks ago. It powered up and booted up properly, but always had problems connecting with to CircuitBlocks. We’re using a fairly old Mac, running on BigSur V.11.2.

I am unable to access Spencer via CircuitBlocks. The app loads on the Mac, but if I click on Spencer Settings I can’t actually change anything on the options - can’t change the temperature units or specify a WiFi - it’s all shaded, for lack of a better term. It is definitely powered up, but seems like it’s not communicating with the computer.

I tried to restore firmware as well but get the notification “Upload error. Check your device then try again.”

Any ideas on how to tackle this?

Thanks,

Rod Diaz

Just to check, did you tell spencer to “enter configuration mode”?

We certainly did. Spencer did respond to that, and the patterns on the screen changed accordingly.

But even if we didn’t - shouldn’t attempting to re-install firmware override that? We tried that as well with no luck.

Rod

Hi @Rod_Diaz,

Thank you for supporting our work and welcome the forum.

Please, navigate to the home screen and press the “Send error report” button on the bottom of the screen.
Write down your error report ID and send it to us with any relevant information via email to [email protected]

Thank you